Bug 448514 - paraview crashes with segmentation fault upon start
paraview crashes with segmentation fault upon start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: paraview (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 08:18 EDT by Matt Thompson
Modified: 2008-05-27 11:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-27 11:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace output for paraview (618.68 KB, application/octet-stream)
2008-05-27 08:20 EDT, Matt Thompson
no flags Details

  None (edit)
Description Matt Thompson 2008-05-27 08:18:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
I recently installed paraview to try it out.  Unfortunately, upon start it crashes with a Segmentation fault.  From dmesg:

paraview[16682]: segfault at 0 rip 2aaabba72aae rsp 7fffb3e38d80 error 4

I have generated a strace file using:

strace -o paraview.trace paraview

I did this because long ago someone said to do this with another program.  And, well, I don't know gdb.

Version-Release number of selected component (if applicable):
paraview-3.2.1-3.fc8.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Run paraview
2. 
3.

Actual Results:
Segmentation fault

Expected Results:
Paraview should run and not crash.

Additional info:
My smolt information is:

http://www.smolts.org/client/show/pub_39b3535b-b6a4-4256-b19d-0bc9e79c7107
Comment 1 Matt Thompson 2008-05-27 08:20:00 EDT
Created attachment 306762 [details]
strace output for paraview

This output generated by:

> strace -o paraview.trace paraview
Comment 2 Matt Thompson 2008-05-27 08:35:38 EDT
And, because I'm an idiot, I have also tried this in various ways.  The above is
when I just run paraview without calling pvserver.  Maybe the Fedora version
cannot do this?  (I've never installed and setup Paraview myself, so perhaps I
missed a configuration step.)

But, in case pvserver must be started explicitly, I started pvserver in various
ways.  I tried:

pvserver
pvserver --use-offscreen-rendering
mpirun -np 4 /usr/bin/pvserver
mpirun -np 4 /usr/bin/pvserver 

Now, I note that I actually have MPICH on this box, and so I'm more interested
in a "non-parallel" version just for my own learning use (since MPICH + OpenMPI
can be...fun).  But I thought I'd try anyway.  Also, I have tried the server
commands above as both root and my local user.
Comment 3 Orion Poplawski 2008-05-27 11:17:54 EDT
Can you post "lspci | grep -F VGA"?  Are you using the ATI binary X drivers? 
Anything showing up in /var/log/Xorg.0.log when you run paraview?
Comment 4 Orion Poplawski 2008-05-27 11:20:25 EDT
Also, please run paraview under gdb:

gdb paraview
run

then post the output of "bt" after it crashes.  Thanks!
Comment 5 Matt Thompson 2008-05-27 11:49:20 EDT
(In reply to comment #3)
> Can you post "lspci | grep -F VGA"?  Are you using the ATI binary X drivers? 
> Anything showing up in /var/log/Xorg.0.log when you run paraview?

Yes, I do run the Livna ATI binary drivers.  And, I remember upgrading them at
some point this morning.  So, I did a reboot and voila, paraview now works! 
Guess I'm still not used to rebooting with Linux...on Windows, this would have
been no problem.

Apologies for the inconvience, and thanks for the quick reply.  Closing.

Note You need to log in before you can comment on or make changes to this bug.