This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448523 - stage 1 shows FTP setting window is HTTP url is wrong
stage 1 shows FTP setting window is HTTP url is wrong
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.7
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 09:09 EDT by Alexander Todorov
Modified: 2008-06-23 14:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 14:15:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-05-27 09:09:37 EDT
Description of problem:
After booting with method=http:// pointing to a wrong url (e.g. a typo) anaconda
will try to download stage2 and when that fails it will present the user with
FTP settings window to correct the url, not HTTP settings window.

Version-Release number of selected component (if applicable):
anaconda-10.1.1.89-1

How reproducible:
Always

Steps to Reproduce:
1. Boot: linux method=http://wrong-url
2.
3.
  
Actual results:
User is presented with FTP settings window instead of HTTP one.

Expected results:
User is presented with HTTP settings window so they can correct the url

Additional info:
Going back after the FTP window is shown reveals that the installation method is
set to FTP. 
After choosing HTTP and filing a wrong url the user will be correctly presented
with the HTTP settings window, so they can correct the url.
Comment 1 Chris Lumens 2008-06-23 14:15:38 EDT
Yeah I've looked at fixing this before, but the code is just not at all laid out
in a manner that makes it easy.  I don't really think there's much we can do
here since it's more work than it's worth, especially when the workaround is to
just reboot.  You're still in the loader so you haven't gotten very far yet.

The good news is this will be fixed up for RHEL6.

Note You need to log in before you can comment on or make changes to this bug.