This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448530 - RFE: remember monitor settings
RFE: remember monitor settings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 09:56 EDT by Jeremy Katz
Modified: 2014-06-18 05:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 13:49:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
monitors.xml (2.41 KB, text/plain)
2008-07-08 23:27 EDT, Jeremy Katz
no flags Details

  None (edit)
Description Jeremy Katz 2008-05-27 09:56:51 EDT
The use case I have with gnome-display-properties is coming into the office and
plugging in the external monitor.  It'd be nice to have the settings remembered
for the specific monitor and then default to that when it's plugged in rather
than requiring doing it manually each time.
Comment 1 Matthias Clasen 2008-07-08 12:25:36 EDT
That is supposed to work, I believe.

Do you have $HOME/.gnome2/monitors.xml ? 
What does it contain ?
Comment 2 Jeremy Katz 2008-07-08 23:27:04 EDT
Created attachment 311338 [details]
monitors.xml

Here's the monitors.xml I have.  And if it's supposed to do something, it's not
at all obvious how it's supposed to be triggered -- it definitely doesn't just
happen.  And nothing obvious in the capplet.
Comment 3 Matthias Clasen 2008-07-10 00:27:13 EDT
Reassigning to ssp, who wrote this stuff.
Comment 4 Søren Sandmann Pedersen 2008-07-10 11:31:58 EDT
The monitors are detected at login time, and it should pick the same
configuration as last time it saw those monitors. Also, hitting fn-F7 should at
the moment do essentially the same as logging out and logging in.

Do these things work? And if fn-F7 doesn't, what, if any, events do you get in xev?

Also, the office monitor, is that a Sony, a Philips, or a Samsung?

(I do think we need something better than fn-F7, maybe a panel menu or
something, or even hotplug events).
Comment 5 Jeremy Katz 2008-07-10 12:13:35 EDT
The one I'm using now is the Samsung.  And I don't think fn-f7 worked, but I'll
try again the next time I'm in the office (or alternately, I'll try it with the
monitor I have at home).  Doing it right now definitely looks like some form of
randr is going on (as the screen flickers)
Comment 6 Jeremy Katz 2009-03-24 13:49:53 EDT
I think this is working fine now

Note You need to log in before you can comment on or make changes to this bug.