Bug 448555 - Writer crash with MS Word produced documents
Writer crash with MS Word produced documents
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hyphen (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 12:53 EDT by Frederic Touboul
Modified: 2008-06-06 03:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.3.1-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-06 03:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of the crashed writer session (8.79 KB, text/plain)
2008-05-27 12:53 EDT, Frederic Touboul
no flags Details

  None (edit)
Description Frederic Touboul 2008-05-27 12:53:08 EDT
Description of problem:

When opening some documents, writer hangs with the following crash information
(see attached file). The documents are correctly open, but Writer crashes a few
seconds later (without any user action). All incriminated documents are opened
without problems by Openoffice 2.4 in Windows or other Linux distribution
without problems.


Version-Release number of selected component (if applicable):
2.4.0-12.8

How reproducible:
Almost always when opening the incriminated document alone. When it is opened
after others, or when several documents are opened, the crash does not always
happen. Unfortunately, I cannot provide any of the incriminated documents for
confidentiality reasons. They were produced primarily with Microsoft Word, and
contain several embedded objects (including Microsoft Visio graphics). When
saving the files to ODT format files, and opening them again, the problem still
exists.

Steps to Reproduce:
1. Open the incriminated document in Writer when no other documents are opened
2.
3.
  
Actual results:
Writer crashes and shows a backtrace window.

Expected results:
Writer opens the document without problem

Additional info:
Comment 1 Frederic Touboul 2008-05-27 12:53:08 EDT
Created attachment 306795 [details]
backtrace of the crashed writer session
Comment 2 Caolan McNamara 2008-05-27 14:21:50 EDT
You say you can sometimes open them, if something is already open, so can you
use format->character and report what "language" is set on e.g. the first
character of the document. Because it looks like a spell-checker related error
Comment 3 Caolan McNamara 2008-05-27 14:42:08 EDT
I could have sworn I fixed a bug like this before in hunspell, but that should
be included in the current version. 

What's the output of rpm -q hunspell ? Should be hunspell-1.2.1-6 (though for an
unrelated fix hunspell-1.2.1-7 is in testing, and that should be ok too)

Feel free to email me directly a sample document
Comment 4 Caolan McNamara 2008-05-28 08:04:35 EDT
Can you try this for me and tell me if it fixes this for you.

rpm --upgrade http://people.redhat.com/caolanm/hyphen-2.3.1-2.fc9.i386.rpm
Comment 5 Fedora Update System 2008-05-28 08:38:49 EDT
hyphen-2.3.1-2.fc9 has been submitted as an update for Fedora 9
Comment 6 Frederic Touboul 2008-05-28 09:20:39 EDT
The hyphen-2.3.1-2.fc9 package solved my problem -- thanks a lot for your support.

For information:

+ The language used in the incriminated documents is set as English (USA). In
the original Word documents, they are sometimes set to English (South Africa).

+ The hunspell version installed here is hunspell-1.2.1-6.fc9.i386
Comment 7 Caolan McNamara 2008-05-28 12:25:43 EDT
Undoubtedly it's the hyphenation feature colliding with spell checking
Comment 8 Fedora Update System 2008-05-30 22:12:51 EDT
hyphen-2.3.1-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hyphen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4711
Comment 9 Fedora Update System 2008-06-06 03:49:54 EDT
hyphen-2.3.1-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.