Bug 44856 - xfs startup doesn't strip missing fonts
Summary: xfs startup doesn't strip missing fonts
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-18 14:37 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-01 12:52:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to /etc/rc.d/init.d/xfs to rebuild font dir if fonts are missing (414 bytes, patch)
2001-06-18 14:37 UTC, Jonathan Kamens
no flags Details | Diff

Description Jonathan Kamens 2001-06-18 14:37:15 UTC
The files /usr/X11R6/lib/X11/fonts/100dpi/fonts.dir and
/usr/X11R6/lib/X11/fonts/75dpi/fonts.dir both list fonts that aren't
actually included in the XFree86-100dpi-fonts or XFree86-75dpi-fonts
package.

It could be argued that that's a bug, but the more significant bug is that
the xfs startup script doesn't compensate for this problem by running
mkfontdir before starting xfs.

Logic has been added to the script to only run mkfontdir when it is
"needed", but one case where it is "needed" is not detected in that logic
-- when fonts are listed in fonts.dir which don't actually exist in the
font directory.

I will attach a patch that adds this logic to the script.

Comment 1 Jonathan Kamens 2001-06-18 14:37:40 UTC
Created attachment 21246 [details]
patch to /etc/rc.d/init.d/xfs to rebuild font dir if fonts are missing

Comment 2 Owen Taylor 2001-07-10 19:28:52 UTC
The fact that xfs regenerates fonts.dir, fonts.scale on startup
is already rather questionable. I believe extending this behavior
would be a bad idea.

(The current script has the slight problem that if you have a directory
with mixed Type1 and TrueType fonts, your fonts.scale will
be overwritten.)

The problem is simply that an incorrect fonts.dir was packaged,
and I believe this has been fixed now.

Comment 3 Mike A. Harris 2001-09-18 07:25:34 UTC
I am not sure exactly how I would like to see this handled, so I
am defering it for the future.  We'll come back to it some other
time.


Note You need to log in before you can comment on or make changes to this bug.