Bug 44858 - /etc/rc.d/init.d/identd fails if /etc/sysconfig/identd doesn't exist
/etc/rc.d/init.d/identd fails if /etc/sysconfig/identd doesn't exist
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pidentd (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-18 10:51 EDT by Jonathan Kamens
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-18 10:52:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make /etc/rc.d/init.d/identd check for /etc/sysconfig/identd before including it (258 bytes, patch)
2001-06-18 10:52 EDT, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2001-06-18 10:51:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.19curl1 i686)

Description of problem:
The script /etc/rc.d/init.d/identd doesn't check if /etc/sysconfig/identd
exists before trying to execute it.  It should, in the same way as many
other init scripts.


How reproducible:
Always

Steps to Reproduce:
Delete /etc/sysconfig/identd, if it exists.
Run /etc/rc.d/init.d/identd restart.

	

Actual Results:  You get an error about /etc/sysconfig/identd being
missing.

Expected Results:  identd should be started.


Additional info:
Comment 1 Jonathan Kamens 2001-06-18 10:52:36 EDT
Created attachment 21248 [details]
patch to make /etc/rc.d/init.d/identd check for /etc/sysconfig/identd before including it
Comment 2 Trond Eivind Glomsrxd 2001-06-18 19:35:59 EDT
OK, I added a patch to fix this (since it is included in the package it
shouldn't ever be missing, but...).  3.0.12-7

Note You need to log in before you can comment on or make changes to this bug.