Bug 44860 - ypbind does not work at all on new 7.1 installs even with RHBA-2001-076 applied
ypbind does not work at all on new 7.1 installs even with RHBA-2001-076 applied
Status: CLOSED DUPLICATE of bug 37463
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-18 11:05 EDT by Brock Murch
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 10:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brock Murch 2001-06-18 11:05:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
ypbind fails evey time. I cannot bind to a nis server at all on a new
installation. This occurs on every install. nis servers running and RH 7.0
and older
installs work fine.  RHBA-2001-076 does not help this problem and it
appears only on completely new installations - not upgrades.


How reproducible:
Always

Steps to Reproduce:
1. New Install RH 7.1 - not an upgrade	
2. /etc/init.d/ypbind start
3. ypbind -[FAILED]
	

Actual Results:  Fails every time. It has been tried on several machines

Expected Results:  ypbind [OK]

Additional info:

SOLUTION:
ypbind works if you install RH 7.0 first with this package, and then do a
complete OS upgrade to 7.1.

I suspect that the package that ships with RH 7.1 is relying on some libs
from 7.0 that are not included in the 7.1 distribution.
Comment 1 Alexei Podtelezhnikov 2001-06-19 00:53:12 EDT
I have a suspicion that you never heard of ipchains, which became available in 
default installation of rh71. If 
so, "mv /etc/sysconf/ipchains /etc/sysconf/ipchains.old" and reboot. This will 
disable ipchains. However, I suggest that you read about ipchains and than 
enable rpc traffic properly.
Comment 2 Brock Murch 2001-06-19 10:43:12 EDT
I have heard of ipchains and use it in 2.2 installs, however, I am not an 
expert in it.

Nevertheless, /etc/sysconf/ipchains does not exist. And:

/etc/init.d/ipchains status
Chain input (policy ACCEPT):
Chain forward (policy ACCEPT):
Chain output (policy ACCEPT):

So that shouldn't pe the problem... and why does it work is doing an upgrade 
from 7.0 but not on a fresh (clean) install on 7.1.
Comment 3 Dennis Morse 2001-06-22 12:58:36 EDT
I found and fixed a bug in the Redhat Linux 7.1 /etc/rc.d/init.d/ypbind
startup script. The bug is that ypbind doesn't wait to give NIS a chance to
bind to an NIS server before continuing. Other services that require NIS may
fail to start because the client is not bound yet.  The critical service
that we use is autofs, which is the very next thing to start. On fast
machines this can fail because ypbind has not bound to a server yet.

Redhat 7.0 worked fine, but the critical "sleep 1" was removed from the
while loop in 7.1.  The differences between the original and my version are as
follows:

prompt> # diff -c ypbind.redhat.7.1 ypbind
*** ypbind.redhat.7.1   Sat Mar  3 12:37:41 2001
--- ypbind      Wed Jun 20 18:08:22 2001
***************
*** 33,38 ****
--- 33,39 ----
        fi
        echo -n $"Binding to the NIS domain... "
        daemon ypbind $OTHER_YPBIND_OPTS
+       sleep 1
        echo
          # the following fixes problems with the init scripts continuing
        # even when we are really not bound yet to a server, and then things
***************
*** 39,52 ****
        # that need NIS fail.
        pid=`pidofproc ypbind`
        if [ -n "$pid" ]; then
!         echo -n $"Listening for an NIS domain server."
!         times=1
!         until ypwhich > /dev/null 2>&1 || [ "$times" = "3" ]
          do
             RETVAL=$?
               echo -n "."
             times=$[$times+1]
          done
        fi
        if [ $RETVAL -eq 0 ]; then
            touch /var/lock/subsys/ypbind
--- 40,56 ----
        # that need NIS fail.
        pid=`pidofproc ypbind`
        if [ -n "$pid" ]; then
!         echo -n $"Listening for an NIS domain server: "
!         times=0
!         until ypwhich > /dev/null 2>&1 || [ "$times" = "10" ]
          do
             RETVAL=$?
               echo -n "."
+            sleep 1
             times=$[$times+1]
          done
+         ypwhich
+         RETVAL=$?
        fi
        if [ $RETVAL -eq 0 ]; then
            touch /var/lock/subsys/ypbind
Comment 4 Florian La Roche 2001-07-24 07:22:24 EDT
can you please check if the current rawhide version works ok for you?

Thanks,

Florian La Roche
Comment 5 Raymond Kwong 2001-07-26 16:13:11 EDT
I have a similar problem. All the ypbind-mt versions, starting with ypbind-1.6
from Redhat 7.0, to ypbind-1.7-6, ypbind-1.7-8, ypbind-1.8, and even the ypbind
compiled from the source of ypbind-mt-1.8 do not work on a Redhat 7.1
workstation connecting to a Redhat 6.2 ypserver (1.3.9).
Even /sbin/ypbind -broadcast does not work. However, our Redhat 6.2 workstations
running ypbind-1.7-0.6 connect to the ypserver with no problems. The only ypbind
version I have tried that actually works on the Redhat 7.1 workstation is
ypbind-3.3-29 from Mandrake. On the other hand, ypbind-1.8 works on a Mandrake
8.0 workstation. So the problem appears to be peculiar to Redhat 7.1. I have
tried running different patches to the ypbind script in /etc/rc.d/init.d, with
the same result (failure).
Comment 6 Raymond Kwong 2001-07-27 00:57:49 EDT
I have succeeded in getting ypbind-mt-1.8 to work on Redhat 7.1. There is a 
problem with the ypbind script in /etc/rc.d/init.d. A new patch was posted by 
hjl@gnu.org in comments related to bug #37463. I used that script to replace 
the ypbind in /etc/rc.d/init.d. I also used ypbind compiled from the source of 
ypbind-mt-1.8 to replace the ypbind in /sbin from ypbind-1.7-8. This particular 
combination works for me when I restart ypbind in /etc/rc.d/init.d.
Comment 7 Alexander Larsson 2002-03-21 10:51:43 EST

*** This bug has been marked as a duplicate of 37463 ***

Note You need to log in before you can comment on or make changes to this bug.