Bug 448600 - mounting gfs2 partitions causes avc
mounting gfs2 partitions causes avc
Status: CLOSED DUPLICATE of bug 435945
Product: Fedora
Classification: Fedora
Component: gfs2-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Whitehouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 15:34 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 06:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-05-27 15:34:21 EDT
type=1400 audit(1211930671.516:7): avc:  denied  { sys_module } for  pid=2818
comm="mount.gfs2" capability=16
scontext=system_u:system_r:mount_t:s0-s0:c0.c1023
tcontext=system_u:system_r:mount_t:s0-s0:c0.c1023 tclass=capability
Comment 1 Daniel Walsh 2008-05-27 16:24:43 EDT
grrr having the mount command able to load system modules is just wrong...

Can't we just have the kernel realize there are gfs2 file systems around and
load the module?  

If I allow this, this would allow all confined domains that need to mount stuff
the ability to load kernel modules.
Comment 2 Chris Feist 2008-05-27 17:51:21 EDT
Steve,

What can we do to get these modules to auto load when we try to mount a gfs
filesystem?  (without doing it in mount.gfs2)

Comment 3 Steve Whitehouse 2008-05-28 03:28:15 EDT
The modules do autoload when we mount a gfs2 filesystem. The problem is that
mount.gfs2 requires the lock_dlm module to be loaded _before_ we mount the
filesystem.
Comment 4 Steve Whitehouse 2008-05-28 06:21:15 EDT

*** This bug has been marked as a duplicate of 435945 ***

Note You need to log in before you can comment on or make changes to this bug.