Bug 448604 - keyboard mostly locks up, producing beeps
keyboard mostly locks up, producing beeps
Status: CLOSED DUPLICATE of bug 445898
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 15:47 EDT by Pekka Savola
Modified: 2008-07-24 04:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 04:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log of a session that ended in a lockup, and was closed by ctrl-alt-backspace (26.80 KB, text/plain)
2008-05-27 15:47 EDT, Pekka Savola
no flags Details

  None (edit)
Description Pekka Savola 2008-05-27 15:47:16 EDT
Description of problem:
After upgrading from F8 to F9, frequently (every 2-3 days) X keyboard seems to
get "locked up" in a bit strange manner.  Pressing a key (including dead keys
such as Ctrl or Alt) produces a beep.  Special keys do seem to work and will
produce expected results, at least most of the time -- e.g. CTRL-ALT-Backspace,
CTRL-ALT-DEL, and (about 50% of time), CTRL-ALT-F1.  After you press
CTRL-ALT-F1, however, about half of the times, you will get constant beeping;
sometimes this doesn't occur.  In CTRL-ALT-F1 mode, keyboard is working fine.


Version-Release number of selected component (if applicable):
Fedora 9, most importantly:

xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9.i386
xorg-x11-drv-keyboard-1.3.0-3.fc9.i386
xorg-x11-server-common-1.4.99.901-29.20080415.fc9.i386

xfce-mcs-manager-4.4.2-2.fc9.i386





How reproducible:
Wait a couple of days at it occurs all by itself.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Nothing special seems to be printed in xorg.log.  I'd welcome suggestions as
where to start looking at the cause of this problem.
Comment 1 Pekka Savola 2008-05-27 15:47:16 EDT
Created attachment 306829 [details]
xorg log of a session that ended in a lockup, and was closed by ctrl-alt-backspace
Comment 2 Andrew Schultz 2008-05-30 00:06:17 EDT
I'm hitting this too with about the same frequency after upgrading F8->F9.  I've
found that if I hold a key down for a bit, it "works" again although I get a
stream of characters (which is generally not useful).  They also seem to come in
pairs (I can get 2 or 4 but not 1 or 3).  Keyboard works fine in the virtual
terminals and even other X displays (although when I hit this just now, I was
unable to switch, ctrl-alt-fN didn't work).  The first time I hit this, I
attempted to use backspace, which seemed to trigger ctrl-alt-backspace behavior
(X died).
Comment 3 Pekka Savola 2008-05-30 00:33:05 EDT
Andrew, are you also using XFCE, or can we rule that out as a factor?
Comment 4 Andrew Schultz 2008-05-30 00:43:21 EDT
I'm running blackbox + bbkeys.  blackbox has no keyboard interaction (bbkeys
handles that).  I killed bbkeys, but that had no effect.

I've also been able to "fix" this a couple times.  It happened shortly after I
posted the previous comment, and after holding down both ctrl, both alt and both
shift simultaneously, it started making beeps with different frequencies and
enabled scroll lock (the LED came on).  I hit ctrl again and then all was back
to normal.
Comment 5 nvwarr 2008-06-13 09:22:52 EDT
(In reply to comment #4)
> I'm running blackbox + bbkeys.  blackbox has no keyboard interaction (bbkeys
> handles that).  I killed bbkeys, but that had no effect.
> 
> I've also been able to "fix" this a couple times.  It happened shortly after I
> posted the previous comment, and after holding down both ctrl, both alt and both
> shift simultaneously, it started making beeps with different frequencies and
> enabled scroll lock (the LED came on).  I hit ctrl again and then all was back
> to normal.

I have the same problem and I am running fvwm2. I have the same versions of
xorg-x11-drv-keyboard and xorg-x11-server-common as Pekka, but I am using
xorg-x11-drv-ati-6.8.0-14.fc9.i386.

In this state, I can still cut and paste characters with the mouse to build up
commands, so I started xev. I see that it takes a second or so for X to detect a
keypress according to xev. Keys like CTRL-C work only if I press CTRL down first
wait a second and then press C for another second.

This state has occurred several times in the course of a week.
Comment 6 Jeff Dike 2008-07-22 12:01:19 EDT
Same problem, characters come in pairs after you've held the key down long
enough for auto-repeat to start.  Keyclick turns itself on when it was silent
before.

WM is fvwm2.

xorg-x11-drv-keyboard-1.3.0-3.fc9.x86_64
Comment 7 nvwarr 2008-07-23 02:01:13 EDT
(In reply to comment #6)
> Same problem, characters come in pairs after you've held the key down long
> enough for auto-repeat to start.  Keyclick turns itself on when it was silent
> before.
> 
> WM is fvwm2.
> 
> xorg-x11-drv-keyboard-1.3.0-3.fc9.x86_64

I now think the problem is not with xorg at all, but with gnome-settings-daemon,
specifically with the version in the updates not the original version.

If I start gnome-keyboard-properties, when the system is in this hung state
(I've added a button for it, so I can operate it from the mouse) this seems to
restart gnome-settings-daemon which fixes the keyboard, though it also screws up
my X resources and changes the desktop wallpaper. I think the root problem is
that gnome is becoming too intrusive, wanting to take over things even if the
user is using a different window manager.

There seem to be three changes made to gnome-settings-daemon between the
original version and the updates version. One produces this keyboard problem.
One causes gnome to change the desktop wallpaper and the third is a genuine bug
fix, where a space was left out between arguments in a command that was generated.

Downgrading to gnome-settings-daemon-2.22.1-0.2008.03.26.7.fc9.i386.rpm (i.e.
the one which ships with Fedora 9) seems to fix the keyboard problem. At least I
haven't had it for several days now, which wasn't the case before. It seems that
several gnome applications start the settings daemon and it seems to assume that
it should take control of everything, which is very annoying for users of other
window managers, who just want to use a few gnome applications!
Comment 8 Peter Hutterer 2008-07-23 02:24:30 EDT
Please go into System, Preferences, Accessibility. Then tick "Only accept long
keypresses".

Sounds much like this could be the culprit. If so, then we have two bugs to fix:
- the server shouldn't cause two key events
- g-s-d shouldn't randomly switch this option on.
Comment 9 Peter Hutterer 2008-07-23 03:42:19 EDT
Fix pushed upstream as ff1a9b7fea2cfe00bc02a99b919fa1178d4f0b12.

http://cgit.freedesktop.org/xorg/xserver/commit/?h=server-1.5-branch&id=ff1a9b7fea2cfe00bc02a99b919fa1178d4f0b12
Comment 10 Peter Hutterer 2008-07-24 04:17:05 EDT

*** This bug has been marked as a duplicate of 445898 ***

Note You need to log in before you can comment on or make changes to this bug.