Bug 448626 - Intel i915 suspend/resume no longer works in F9 (worked in F8)
Intel i915 suspend/resume no longer works in F9 (worked in F8)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
9
i686 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 18:10 EDT by James Bottomley
Modified: 2013-03-05 22:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bottomley 2008-05-27 18:10:30 EDT
The problem seems to be that F9 in

/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-fujitsu.fdi

Now has a quirk entry for the Fujitsu LifeBook P7120 (my laptop) setting
vbestate_restore to true.  Unfortunately, this mucks with the video bios
settings that the kernel now controls and causes resume to fail about 50% of the
time (usual symptoms are backlight stays off and sometimes X crashes or hangs).

This is the problem statement:

        <match key="system.hardware.product" contains_outof="E4010;P7120">
          <merge key="power_management.quirk.vbestate_restore"
type="bool">true</merge>
        </match>

At or around line 54 in that file.  Removing the P7120 (and changing the match
to contains) fixes the problem.

I suspect there will be a lot of other intel 915 (and other intel graphics
driver) laptops that have the same bug.
Comment 1 Richard Hughes 2008-05-30 07:55:00 EDT
Sure, does the pm-utils in rawhide fix this? For modesetting drivers we just
ignore the quirks.
Comment 2 James Bottomley 2008-05-30 18:33:50 EDT
No ... but it will when there's a 2.6.26 kernel available.  This is what s98
will do then:

smart_kernel_video() 
{
[...]
	# FIXME: a more accurate way of testing this?
	[ -d /sys/module/i915 ] && \
	    [ "$kernel_rev" > "2.6.26" -o "$kernel_rev" = "2.6.26" ] && \
	    return 0;
Comment 3 James Bottomley 2008-06-25 14:59:46 EDT
You just updated hal-info without fixing this!

I noticed because suspend/resume failed when it overwrote the edited version of
20-video-quirk-pm-fujitsu.fdi
Comment 4 Bug Zapper 2009-06-09 21:14:51 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-07-14 11:11:13 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.