Bug 448639 - gcc ICE in simplify_subreg
gcc ICE in simplify_subreg
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 20:24 EDT by Petr Muller
Modified: 2016-09-19 22:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 03:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source (256 bytes, text/plain)
2008-05-27 20:28 EDT, Petr Muller
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 36362 None None None Never

  None (edit)
Description Petr Muller 2008-05-27 20:24:33 EDT
Description of problem: 

following test piece of code (randomly generated C - are those two '!' even 
valid?) makes GCC ICE. 

int main(){
    float c2 = 1.0;
    if ( ! ! c2 * 07ll == 0 ){
    }
}

Version-Release number of selected component (if applicable):
gcc-4.3.0-8.i386

How reproducible:
seems to be reproducible only in 32-bit mode, and without optimizations

Steps to Reproduce:
1. gcc t.c
  
Actual results:
ICE

Expected results:
no ICE

Additional info:
I tried this with RHEL5 and upstream gcc (HEAD cca month back), both were 
affected too.
Comment 1 Petr Muller 2008-05-27 20:27:07 EDT
forgot the ICE itself:

# gcc t.c
t.c: In function ‘main’:
t.c:5: internal compiler error: in simplify_subreg, at simplify-rtx.c:3818
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc3kyGnf.out file, please attach this to 
your bugreport.
Comment 2 Petr Muller 2008-05-27 20:28:31 EDT
Created attachment 306863 [details]
preprocessed source

alhough there's nothing much to preprocess, here's preprocessed source

Note You need to log in before you can comment on or make changes to this bug.