Bug 448640 - rsyslogd takes CPU all the to 99% to 100%
rsyslogd takes CPU all the to 99% to 100%
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 20:24 EDT by sangu
Modified: 2013-06-18 10:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 07:42:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-05-27 20:24:45 EDT
Description of problem:
rsyslogd takes CPU all the to 99% to 100%

see : https://www.redhat.com/archives/fedora-test-list/2008-May/msg00861.html
Version-Release number of selected component (if applicable):
3.19.3-1.fc10

How reproducible:
always

Steps to Reproduce:
1. Update rsyslog-3.19.3-1.fc10
2. Reboot
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pierre Ossman 2008-05-28 03:03:38 EDT
+1

It's the third thread (fourth created judging from the pids) that's the culprit.
No syscalls made by it. gdb backtrace:

#0  0xb8078ba2 in Syslog () from /usr/lib/rsyslog/imklog.so
#1  0xb8079376 in ?? () from /usr/lib/rsyslog/imklog.so
#2  0xb8079450 in klogLogKMsg () from /usr/lib/rsyslog/imklog.so
#3  0xb80789d4 in ?? () from /usr/lib/rsyslog/imklog.so
#4  0x0805954e in ?? ()
#5  0x435e451f in start_thread () from /lib/libpthread.so.0
#6  0x4351abde in clone () from /lib/libc.so.6

There is no activity in dmesg.
Comment 2 Peter Vrabec 2008-05-28 04:50:55 EDT
problem should be solved in rsyslog-3.19.4-1.fc10. Let me know, please. thnx.
Comment 3 Didier 2008-11-14 03:58:13 EST
Seeing this again with latest rsyslog-3.21.3-4.fc10.i386 .
Comment 4 Tomas Heinrich 2008-11-18 10:29:14 EST
This bug has been fixed and is not present in rsyslog-3.21.3-4, so what you're experiencing is probably unrelated to it.
I haven't seen it in a quick test run. Do you have a reliable way to reproduce it?
Have you done any changes to your configuration file?
Comment 5 Didier 2008-11-18 11:11:40 EST
No changes to the configuration file.

To complicate the issue, I'm only seeing it on one of my 3 F-10 installations, about 50% of the time.

Would you fancy an strace log ?
If you rather prefer giving gdb instructions, I'll try to follow them too (rsyslog-debuginfo required, I guess ?).
Comment 6 Tomas Heinrich 2008-11-18 12:46:10 EST
Any additional information would be useful.
strace log and if possible a backtrace from gdb - debuginfo is needed.

Does it always appear at any precise time after boot?
Comment 7 Didier 2008-11-18 15:18:17 EST
I will have a look at that installation the next few days (it's a station which is not very often rebooted).

Concerning the gdb backtrace : I asked for instructions because I am not closely acquainted with gdb.  :)
Comment 8 Tomas Heinrich 2008-11-19 09:48:13 EST
Sorry for being so brief about the instructions, here they are:
  # gdb rsyslogd <pid>
  gdb may complain about missing debuginfo,
  e.g. "Missing separate debuginfos, use: debuginfo-install gcc.i386 zlib.i386"

  (gdb) bt
  This will display the backtrace.

Note You need to log in before you can comment on or make changes to this bug.