This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448656 - touchpad mouse gone berserk on Dell XPS M1530 laptop
touchpad mouse gone berserk on Dell XPS M1530 laptop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-27 23:53 EDT by Hans
Modified: 2008-12-09 23:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:27:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.xlog (19.28 KB, text/plain)
2008-05-28 04:08 EDT, Matěj Cepl
no flags Details
dmesg (37.06 KB, text/plain)
2008-05-28 04:09 EDT, Matěj Cepl
no flags Details
Xorg.0.log (19.49 KB, text/plain)
2008-05-28 04:09 EDT, Matěj Cepl
no flags Details
Xorg.0.log.old (20.85 KB, text/plain)
2008-05-28 04:14 EDT, Matěj Cepl
no flags Details
kernel build configuration (41.82 KB, text/plain)
2008-07-11 03:00 EDT, Andreas Ericsson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 164378 None None None Never

  None (edit)
Description Hans 2008-05-27 23:53:17 EDT
Description of problem:

It appears no one maintains the original bug # 164378 anymore where I reported
that the issue could be replicated in the latest Fedora release.

I have a brand new Dell XPS M1530 laptop with x84_64 Fedora 9 installed and the
touchpad mouse suffers this 'crazy mouse syndrome'.
X can only be used via keyboard hotkeys. The issue starts when X loads the mouse
driver during the startup process.

I haven't tried to install the synaptic driver or to change anything in the
kernel, the system is the default installation.

I used graphical installation and the touchpad mouse was working fine except the
tap function. I had to use the touchpad button to select the installation options.
After loading the GUI however the mouse just gone berserk.

Version-Release number of selected component (if applicable):

Fedora 9 x86_64 with updates on 27/05/2008

How reproducible:

Install the OS on the specified laptop and try to use the touchpad mouse after
it finished the installation and rebooted the host.

Actual results:

When you touch it the mouse starts running all over the screen like crazy and
triggers the click effect on left and right buttons randomly then eventually
ends up in the bottom left corner of the screen.

Additional info:

Uploaded logs can be found at https://bugzilla.redhat.com/show_bug.cgi?id=164378#c11
Comment 1 Matěj Cepl 2008-05-28 04:08:59 EDT
Created attachment 306897 [details]
anaconda.xlog
Comment 2 Matěj Cepl 2008-05-28 04:09:12 EDT
Created attachment 306898 [details]
dmesg
Comment 3 Matěj Cepl 2008-05-28 04:09:24 EDT
Created attachment 306900 [details]
Xorg.0.log
Comment 4 Matěj Cepl 2008-05-28 04:14:32 EDT
Created attachment 306901 [details]
Xorg.0.log.old
Comment 5 Matěj Cepl 2008-05-28 04:25:17 EDT
Let's forget bug 164378 -- it is most likely red herring (things have really
changed a lot since Fedora 4 and we haven't seen anything like that since much).
So, let's treat this as a new bug.
Comment 6 Hans 2008-07-03 18:36:38 EDT
Hi,

Is there any development on this case?
Can we have some update, please?

Thanks!

Istvan
Comment 7 Andreas Ericsson 2008-07-07 06:14:35 EDT
I have the same issue. It seems to be mitigated somewhat by having an external
mouse and specifying the protocol automatically for that one (imps2 for me), but
the issue doesn't go away completely.

I'm also having issues of getting random junk keyboard input (I haven't tried
compiling a kernel of my own without any kind of mouse support, but I guess that
would solve the junk input problem).

Setting the default runlevel to 3 in /etc/inittab still makes me get tons and
tons of junk input, seemingly from the keyboard (I'm a notoriously lazy bastard;
my left thumb rests more or less constantly on the touchpad). It seems the input
is identical to that of pressing F7 (^[[18~) about a billion times per second.

n the command line, it only shows up as a string of '~'. The keyboard is useless
while those are being printed and a short while after, while the kernel tries to
reinitialize the mouse pointer.

The touchpad and external mouse both work flawlessly when booted into Windows
Vista, so hardware malfunctions can safely be ruled out.

I'll log back to windows now and try to attach some dmesg output. It's littered
with strings like this (from memory):

    Bad input from KBC - bad parity

There are about 30-60 of those, followed by "trying to reinitialize input device
on /devices/input/serio<x>", followed by a failure message, followed by a "New
input device registered at /devices/input/serio<x+y>" (or some such). While the
re-initializing goes on, keyboard and both the mice are frozen and nothing can
be done to fix it.

I'm well-versed in git (I helped write the silly thing) and I work as a C
programmer, so I'd be happy to help resolving this issue.

The problem is present with the latest fedora kernel (2.6.25.9-76.i686, I think)
as well as with latest master from Linus' tree (v2.6.26-rc9-5), and I noticed it
at the end of the fedora 8 period as well (I just upgraded), so I don't think
it's an Xorg issue.
Comment 8 Andreas Ericsson 2008-07-08 08:12:17 EDT
This is indeed a kernel issue. When booting with the 2.6.23.1-42.fc8 kernel, I
get the (much more pleasant) "tapping doesn't work" issue and the touchpad is
properly recognized as an "AlpsPS/2 ALPS GlidePoint" device rather than a "PS/2
Generic Mouse" in the dmesg output.

As a work-around, adding "psmouse.proto=bare" to the kernel boot options sort-of
works, but seems to cause a conflict between my USB mouse and the touchpad, so
that the external mouse moves sluggishly 5-10 seconds out of every two minutes
(to the point where it looks frozen). Not a big issue, but annoying to the point
where this was still itching enough for me to scratch it.


It's worth noting that I was unable to use the nvidia kernel module with the
2.6.23.1-42 kernel though, as the latest (and working) nvidia module doesn't
come pre-compiled for 2.6.23.1-42. I've been burned too many times before from
manually installing it to feel safe doing that again.

It might be worth setting hardware to i686 instead of x86_64. I don't think Dell
ships XPS laptops with 64 bit CPU's (although I can't imagine it being relevant
for this case, since the mouse input drivers all work on 8-bit fields anyways).

Will try my way up through the kernels and holler when I know the first one that
breaks. Once I get a narrow enough window I'll start bisecting and bring this to
linux-input@vger.

Incidentally, do you happen to have any quick way of testing new kernel images?
I've tried googling/asking around, but I haven't found anything so far that
doesn't involve creating ramdisks and rebooting (which works, but it's slow).
Comment 9 Andreas Ericsson 2008-07-08 10:43:57 EDT
kernel-2.6.24.3-12.fc8 (and all later kernels) exhibits the problem.
kernel-2.6.23.1-42.fc8 (and presumably earlier) "works" (apart from touchpad
tapping, that is).

I have no idea which (git) commits these two kernels were built from. I'm having
a hard time matching the linux-2.6.23 tarball to the v2.6.23 tag of the
"official" linux git repo, so trying to find the exact (tree) match for when
I've added the patch-2.6.23.1 is all but impossible. It seems one could start a
bisect with

    git bisect start v2.6.24 v2.6.23

though and almost certainly get some good mileage out of it. There are two
merges in that range, but also some really trivial typo-fixes. The most likely
culprit is actually the first one.

I'll do that now and see where it leads to.
Comment 10 Andreas Ericsson 2008-07-11 02:47:56 EDT
As posted to linux-input@vger:

This problem is not in v2.6.26-rc9-56-g6329d30 from Linus' tree
(6329d3021bcfa9038621e6e917d98929421d8ec8). Now it's just the
touchpad tapping that doesn't work any more, which I personally
don't really care about.

It would be nice to see a quick kernel upgrade to 2.6.26 once
it goes stable so I don't need to use self-compiled kernels
anymore.

I'll send my kernel build config as attachment in a new post soon.
Comment 11 Andreas Ericsson 2008-07-11 03:00:44 EDT
Created attachment 311553 [details]
kernel build configuration

This is the kernel build .config I'm using at the moment, with
v2.6.26-rc9-56-g6329d30 from Linus' tree
(6329d3021bcfa9038621e6e917d98929421d8ec8).

For future references; It would be nice if CONFIG_IKCONFIG and
CONFIG_IKCONFIG_PROC could be set to M for fedora kernels. That way one won't
have to look all over the web to find the build-options used, making it easier
to debug things like this on ones own.

It would be even nicer if there was a git repository somewhere with one branch
for each supported arch (it doesn't matter if the branches get rewritten every
time there's a new release) so one can easily check the actual code ones own
kernel was built from and also make modifications to it.
Comment 12 Andreas Ericsson 2008-07-18 09:01:14 EDT
Still no go with kernel-2.6.25.10-86.fc9.i686. v2.6.26 from Linus' tree works
nicely though.
Comment 13 Peter Hutterer 2008-07-20 20:54:10 EDT
Reassigning to kernel.
Comment 14 Chuck Ebbert 2008-07-20 22:03:03 EDT
(In reply to comment #11)
> 
> For future references; It would be nice if CONFIG_IKCONFIG and
> CONFIG_IKCONFIG_PROC could be set to M for fedora kernels. That way one won't
> have to look all over the web to find the build-options used, making it easier
> to debug things like this on ones own.

The config is always installed as /boot/config-$(uname -r)
 
> It would be even nicer if there was a git repository somewhere with one branch
> for each supported arch (it doesn't matter if the branches get rewritten every
> time there's a new release) so one can easily check the actual code ones own
> kernel was built from and also make modifications to it.

The full SRPM used to build the kernel is always made available.

Complete directions for how to build your own kernel from the SRPM are here:

  http://fedoraproject.org/wiki/Docs/CustomKernel
Comment 15 Hans 2008-07-30 00:53:00 EDT
Thanks guys the fantastic effort to get this issue fixed.
The recommendation to include psmouse.proto=bare unfortunately didn't work in my
case and I'm not a kernel guru to play with the different trees.

The latest comment on https://bugzilla.redhat.com/show_bug.cgi?id=164378#c13
however seems to fixed my issue and even though I still can't tap on the
touchpad to click on objects, at least I can now use the mouse to do the work on
my M1530

"Pass the kernel parameter i8042.nomux=1 at boot and the issue will not affect
you XPS M1530 with the synaptics touchpad.
I saw this issue manifest when I moved from BIOS revision 0.6 to BIOS revision
0.8 on my own XPS M1530."
Comment 16 my_linux 2008-08-25 12:08:35 EDT
The entry in grub.conf works for me too but still no tap possibility on my M1530 BIOS A09.

I have tried Fedora 10 Alpha Live x86_64 using USB stick and not had a problem on booting in to GNOME.
Comment 17 Hans 2008-08-26 08:18:17 EDT
A new development on this issue...

I use Gnome on this laptop and when I suspend the machine, close the lid then restart the session again, suddenly the mouse driver detects the taps and works as normal.
I haven't changed anything extra, only added the 'i8042.nomux=1' parameter to the kernel boot ones.

Now the mouse is working fine with all the features I think if I boot into Fedora, login, suspend the host, then revive it again.
I can even use up/down and left/right scrolls on the side of the touchpad.

weird....
Comment 18 my_linux 2008-08-26 09:28:31 EDT
I have found an article on fedoraforum.org which is called " How do I enable 'tap to click' on mousepad?"

There it is suggested the following entry be added to xorg.conf which will then allow tapping function. I shall try this when I get home if you can it might be worth giving it a go too.

#Another section for Touchpad
Section "InputDevice"

       Identifier "Touchpad"
       Driver "synaptics"
       Option "SendCoreEvents"
       Option "Protocol" "auto-dev"
       Option "TapButton1" "1"
       Option "TapButton2" "2"
       Option "TapButton3" "3"
       Option "SHMConfig" "on"
Comment 19 my_linux 2008-08-26 09:32:40 EDT
There is also info ref the suspend / resume (similar?) here:

https://bugzilla.redhat.com/show_bug.cgi?id=439386
Comment 20 Hans 2008-11-10 06:20:37 EST
Dear DEV people,

Just wondering with only a couple of days left until the official release of the new Fedora if there's any chance to get this issue fixed in v10?

Thanks!
Comment 21 Chuck Ebbert 2008-11-25 11:33:37 EST
Fixed in:
2.6.27.7-51.fc9
2.6.27.7-126.fc10
Comment 22 Fedora Update System 2008-11-27 21:19:14 EST
kernel-2.6.27.7-53.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.7-53.fc9
Comment 23 Fedora Update System 2008-12-02 20:26:57 EST
kernel-2.6.27.7-53.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2008-12-09 23:35:57 EST
kernel-2.6.27.7-53.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.