Bug 4487 - pump loses ability to do anything
pump loses ability to do anything
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-11 21:21 EDT by cjr
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 15:42:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cjr 1999-08-11 21:21:44 EDT
Howdy.

I have been able to get pump to a state in which it is
never able to perform its magic.  pump will timeout after
sometime with "Operation failed." but continue to run.
Subsequent pump -s or pump -r results in an "Operation
failed."  pump continues to operate (in a failed mode).
Of course, kill -KILL works great.

The only solution that I have found to this is rebooting
the computer (unacceptable).  Killing pump, tearing down
the entire network, etc. and restarting pump has no effect.

I have an strace and ltrace of pump if it would be useful
to anyone.

Cheers.
Comment 1 Bill Nottingham 1999-08-12 11:02:59 EDT
Does it still happen with the errata release (0.7.0)?
Comment 2 cjr 1999-08-17 22:00:59 EDT
Hi.  cjr@austin.rr.com in disguise.  Yes, this still happens under the
errata release of 0.7.0.

The specific instances of my problem are as follows.  I have two
computers that are connected to my Time Warner Motorolo cable modem.
It seems that this arrangement allows only one computer to use the
cable modem at a time.  I suspect that the cable modem associates the
MAC address with the computer that is allowed to talk.

To continues, whenever I want to use the Windows box, I run winipcfg
and renew the token.  This reassociates the cable modem with the
Windows box.  At this point, pump because hosed.

(Yes, masquerade.  I know.  I haven't had the time to get a second NIC
yet though since my last one... well... I digress.)

I go through all of the *conceivable* motions to get my system back
into a state where pump will work.  I...

. ifdown eth0 (fails)
. kill pump because pump -r hangs
. network stop
. kill pump in case pump -r was started by ifdown eth0
. rm /var/run/pump.sock
. network start

During network start, pump hangs and fails with Operation failed.
These steps were my latest iteration in attempt to get the machine
working again without having to reboot the machine.  Oh, these steps
are even conducted with the Windows box off the network.

I am fairly certain that it is not a release/renew problem with the
cable modem as it worked before the upgrade to RH 6.0.  Plus, the
Windows box is able to renew regardless if the Linux box has current
control.

Once I reboot, it comes up lickity split.

Cheers.
Comment 3 Erik Troan 2000-02-23 15:42:59 EST
This should be fixed for piglet.

Note You need to log in before you can comment on or make changes to this bug.