This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 448718 - enhancement: leave my window title alone
enhancement: leave my window title alone
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 09:03 EDT by Tom Horsley
Modified: 2008-05-28 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-28 09:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-05-28 09:03:51 EDT
Since we seem to have a new xterm with an active maintainer, I thought I'd
just throw out this enhancement request:

It would be nice if there was a X resource I could set that tells xterm:
"You know those escape sequences programs can send to set the window title?
Well, ignore them utterly - leave my dadgum window title the way I set it."

I'm constantly irritated by this. I run xterm on lots of different systems,
and I give the windows meaningful titles when I create them. Having helpful
/etc/profile junk that changes my titles isn't helpful at all because I
can no longer find the meaningful names.

I suppress this as best I can in my own .profile, but sometimes I have to
su to other users and suddenly my title is screwed up again. It would be nice
to just load a resource setting into my server that would globally suppress
the title changing (at least once the new xterm percolated to all the systems
I use :-).
Comment 1 Miroslav Lichvar 2008-05-28 09:30:34 EDT
Already implemented, it's called allowTitleOps. ;-)
Comment 2 Tom Horsley 2008-05-28 09:39:05 EDT
I swear I looked for that before :-). I must be blind. Thanks for the
pointer and sorry about the noise.

Note You need to log in before you can comment on or make changes to this bug.