Bug 448747 - Net install seems to ignore manual config if a DHCP query had been performed before
Net install seems to ignore manual config if a DHCP query had been performed ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 11:40 EDT by Charles Bedon
Modified: 2008-08-28 16:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-28 16:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Bedon 2008-05-28 11:40:51 EDT
Description of problem:

If you try to switch from a DHCP automatic configuration to a manual one, the
changes are not committed.

Version-Release number of selected component (if applicable):


How reproducible:
Always under any arch

Steps to Reproduce:
1. Use a net-install cd
2. Choose DHCP config for IPV4 (a DHCP server should be available)
3. Choose URL as source. When prompted for the URL, go back to step 2, but this
time select "Manual Config". Fill in the fields with valid values.
4. Next, next, next until the graph installer is running, then go to tty2
(ctrl+alt+F2) and check for ifconfig. It will show the IP address config got by
DHCP, not the one you configured manually. This DHCP config will remain even if
you set new values at the graphical interface. Notice that information at GUI is
right (I mean, it corresponds to the one configured manually), but the actual
config gotten via ifconfig is wrong.
  
Actual results:
The DHCP config can't be changed using anaconda installer

Expected results:


Additional info:
Now, you'd wonder: what if a "ifconfig eth0 xx.xx.xx.xx/route add default gw"
combination is used at tty? It works, i mean, the mirror can be telnet, but the
installer refuses to connect to the right mirror IP address (it stablishes an
udp connection to a 192.168.x.x -i assume some sort of loopback- address). I
used "netstat -natu" to check that. Maybe this last thing has something to do
with other bugs reported around a netinstall against an FTP mirror (which is the
one i'm trying to use), but i have not checked this out.

Workaround: Select "Manual Config" from the beginning.

I needed to switch because the address provided by DHCP has security
restrictions and the manual one hasn't
Comment 1 Chris Lumens 2008-08-28 16:39:06 EDT
This should be fixed in the next build of anaconda by the massive amount of networking code David has gotten done recently.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.