Bug 448767 - odd behavior with vmmouse driver
odd behavior with vmmouse driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmmouse (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 13:37 EDT by Jeff Bastian
Modified: 2008-10-22 09:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 09:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf original (799 bytes, text/plain)
2008-05-28 13:44 EDT, Jeff Bastian
no flags Details
xorg.conf modified for vmmouse (1.09 KB, text/plain)
2008-05-28 13:45 EDT, Jeff Bastian
no flags Details
Xorg.0.log from original xorg.conf (22.55 KB, text/plain)
2008-05-28 13:46 EDT, Jeff Bastian
no flags Details
Xorg.0.log from vmmouse xorg.conf (21.51 KB, text/plain)
2008-05-28 13:47 EDT, Jeff Bastian
no flags Details
xev output with original xorg.conf (985 bytes, text/plain)
2008-05-28 13:48 EDT, Jeff Bastian
no flags Details
xev output with vmmouse xorg.conf (1.30 KB, text/plain)
2008-05-28 13:50 EDT, Jeff Bastian
no flags Details
screenshot of konsole with vmmouse driver (38.35 KB, image/png)
2008-05-28 13:51 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2008-05-28 13:37:58 EDT
Description of problem:
I'm running Fedora 9 under VMware Fusion 1.1.2.  I do not have the VMware Tools
installed because they do not compile correctly (without unofficial patches)
with 2.6.24 and newer kernels.

I'm trying to use the vmmouse driver because it makes the mouse motion much
smoother and the mouse can seamlessly move between the host and virtual
machines.  However, I've noticed some oddities when using the vmmouse driver:

1. Occasionally there are two cursors on the screen.  Only one moves, but
   both change shape, for example, if moving a window.  If I logout and login
   (which restarts X) the second cursor may or may not appear.
2. I cannot add widgets to the desktop in KDE4 with the icon in the upper-right
   corner.  That is, move the mouse to the upper right corner and
   "+ Add Widgets" appears, and if I click on it, nothing happens.  (I can,
   however, right click on the desktop and add widgets using the menu.)
3. If I do a single left-click in Konsole, it selects all text from the mouse
   to the right edge of the konsole.  If I try to click again somewhere to
   unselect, it just selects from the new cursor position to the right edge.

If I switch back to a generic xorg.conf generated by system-config-display, it
uses the 'mouse' driver instead of 'vmmouse' and all of the above problems go
away, except the mouse movement is jerky again and I have to hit CTRL-Apple to
release the cursor from the virtual machine.


Version-Release number of selected component (if applicable):
xorg-x11-drv-vmmouse-12.5.0-1.fc9.i386


How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 9 under VMware Fusion 1.1.2 and apply all updates
2. Modify xorg.conf (see attached) to use vmmouse driver
  
Actual results:
Notice second mouse cursor occasionally, login to KDE and notice you cannot add
widgets using the icon in the upper right, and left-clicking in Konsole selects
text to the right-edge of the konsole window.

Expected results:
Normal mouse behavior

Additional info:
Comment 1 Jeff Bastian 2008-05-28 13:44:49 EDT
Created attachment 306960 [details]
xorg.conf original

xorg.conf generated by system-config-display
Comment 2 Jeff Bastian 2008-05-28 13:45:50 EDT
Created attachment 306961 [details]
xorg.conf modified for vmmouse

xorg.conf modified by me to use the vmmouse driver and use the NoAutoAddDevices
server flag
Comment 3 Jeff Bastian 2008-05-28 13:46:35 EDT
Created attachment 306962 [details]
Xorg.0.log from original xorg.conf

/var/log/Xorg.0.log with original xorg.conf
Comment 4 Jeff Bastian 2008-05-28 13:47:20 EDT
Created attachment 306963 [details]
Xorg.0.log from vmmouse xorg.conf

/var/log/Xorg.0.log from my modified xorg.conf with vmmouse driver
Comment 5 Jeff Bastian 2008-05-28 13:48:45 EDT
Created attachment 306964 [details]
xev output with original xorg.conf

I ran xev and made a single left-click (and was careful not to move the mouse)
inside the xev box and captured these 5 events.  This is with the original
xorg.conf and standard mouse driver.
Comment 6 Jeff Bastian 2008-05-28 13:50:53 EDT
Created attachment 306965 [details]
xev output with vmmouse xorg.conf

I ran xev again with the vmmouse driver and noticed there were two extra
MotionNotify events even though I was careful not to move the mouse.  I picked
up the mouse so the laser could not detect anything and repeated the left click
and it still generated these extra MotionNotify events.
Comment 7 Jeff Bastian 2008-05-28 13:51:57 EDT
Created attachment 306966 [details]
screenshot of konsole with vmmouse driver

After a single left-click in Konsole, notice how the text from the middle of
the window to the right edge is selected.
Comment 8 Jeff Bastian 2008-05-28 13:57:12 EDT
I repeated the xev test under Fedora 8 where the vmmouse driver works fine and
the extra MotionNotify events do not appear.
Comment 9 Peter Hutterer 2008-10-22 00:40:17 EDT
Can you give vmmouse 12.5.2 a try please?

https://admin.fedoraproject.org/updates/xorg-x11-drv-vmmouse-12.5.2-1.fc9

According to Philip Langdale (upstream maintainer), it should fix some issues with xserver 1.5. Not sure if it fixes the issues mentioned here though.
Comment 10 Jeff Bastian 2008-10-22 09:49:34 EDT
Actually, after upgrading to KDE 4.1.x and the problem went away.  Maybe a Qt update or KDE 4.1.x fixed this?  And since then, I've moved on to Fedora 10 Beta and everything is working fine.  I'm not sure what fixed it, but it's fixed!

Note You need to log in before you can comment on or make changes to this bug.