Bug 448776 - Glabels pegs CPU at 100% when dealing with text
Glabels pegs CPU at 100% when dealing with text
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: glabels (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 14:42 EDT by P Jones
Modified: 2008-08-02 20:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-02 20:53:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2008-05-28 14:42:32 EDT
Description of problem: Any action (not just text) is substantially slower in F9
than in F8 on the same computer; drawing a line, inserting a picture, etc. all
take a couple of seconds between mouse action and result. During thsi time the
CPU is at 100%. With text, and I have about 300 TTF fonts installed, typing a
three word sentence can take up to 20 seconds with CPU at 100%.


Version-Release number of selected component (if applicable):
glabels-2.2.2-1.fc9.i386


How reproducible: Start glabels, select a label type. Try to insert some text on
the label. Watch CPU go to 100% and wait for a long time for text to appear. 
  
Expected results: Zippy performance as in F8.


Additional info: I have not tried to see how bad this problem is without all of
the fonts installed, which I will do as soon as possible.
Comment 1 Peter Gordon 2008-06-26 16:25:58 EDT
Thanks for your bug report.

I've finally upgraded my machine to Fedora 9 and am not experiencing this issue.
I've tried it with several label types at random, with no issues. 

Does this happen with only a specific label type? Do you have an example label
file that you could attach which would reproduce it for me?

Also, if you can run the program under strace ('strace glabels' in a Terminal),
what are the last several lines of output when it hangs?
Comment 2 Peter Gordon 2008-07-17 20:45:44 EDT
P Jones, It has been three weeks with no response from you to my prior debugging
inquiries. Are you still experiencing this problem, and did your attempt at
removing some fonts help any?

Please let me know. Thanks!
Comment 3 Peter Gordon 2008-08-02 20:53:49 EDT
It has now been a total of 6+ weeks since my request for further debugging information, with no response. I am left with little choice but to close this bug, in the hopeful assumption that the issue no longer is present.

If you are in fact unavailable until a later date, please feel free to re-open this bug when upon your return if the issue persists.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.