Bug 448778 - RFE: --skip-broken should handle core .soname bumps better
RFE: --skip-broken should handle core .soname bumps better
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 14:47 EDT by Jóhann B. Guðmundsson
Modified: 2014-01-21 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 05:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum-output.log (27.15 KB, text/plain)
2008-05-28 14:47 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2008-05-28 14:47:54 EDT
Description of problem:

See Summary..



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

yum skip-broke does not skip broken packages..

Expected results:

yum skip-broken skipping broken packages..

Additional info:



Man in Black: All right. Where is the poison? The battle of wits has begun. It
ends when you decide and we both drink, and find out who is right... and who is
dead.
Vizzini: But it's so simple. All I have to do is divine from what I know of you:
are you the sort of man who would put the poison into his own goblet or his
enemy's? Now, a clever man would put the poison into his own goblet, because he
would know that only a great fool would reach for what he was given. I am not a
great fool, so I can clearly not choose the wine in front of you. But you must
have known I was not a great fool, you would have counted on it, so I can
clearly not choose the wine in front of me.
Man in Black: You've made your decision then?
Vizzini: Not remotely. Because iocane comes from Australia, as everyone knows,
and Australia is entirely peopled with criminals, and criminals are used to
having people not trust them, as you are not trusted by me, so I can clearly not
choose the wine in front of you.
Man in Black: Truly, you have a dizzying intellect.
Vizzini: Wait til I get going! Now, where was I?
Man in Black: Australia.
Vizzini: Yes, Australia. And you must have suspected I would have known the
powder's origin, so I can clearly not choose the wine in front of me.
Man in Black: You're just stalling now.
Vizzini: You'd like to think that, wouldn't you? You've beaten my giant, which
means you're exceptionally strong, so you could've put the poison in your own
goblet, trusting on your strength to save you, so I can clearly not choose the
wine in front of you. But, you've also bested my Spaniard, which means you must
have studied, and in studying you must have learned that man is mortal, so you
would have put the poison as far from yourself as possible, so I can clearly not
choose the wine in front of me.
Man in Black: You're trying to trick me into giving away something. It won't work.
Vizzini: IT HAS WORKED! YOU'VE GIVEN EVERYTHING AWAY! I KNOW WHERE THE POISON IS!
Man in Black: Then make your choice.
Vizzini: I will, and I choose - What in the world can that be?
Vizzini: [Vizzini gestures up and away from the table. Roberts looks. Vizzini
swaps the goblets]
Man in Black: What? Where? I don't see anything.
Vizzini: Well, I- I could have sworn I saw something. No matter.First, let's
drink. Me from my glass, and you from yours.
Man in Black, Vizzini: [they drink ]
Man in Black: You guessed wrong.
Vizzini: You only think I guessed wrong! That's what's so funny! I switched
glasses when your back was turned! Ha ha! You fool! You fell victim to one of
the classic blunders! The most famous is never get involved in a land war in
Asia, but only slightly less well-known is this: never go in against a Sicilian
when death is on the line! Ha ha ha ha ha ha ha! Ha ha ha ha ha ha ha! Ha ha ha...
Vizzini: [Vizzini stops suddenly, and falls dead to the right]
Buttercup: And to think, all that time it was your cup that was poisoned.
Man in Black: They were both poisoned. I spent the last few years building up an
immunity to iocane powder.
Comment 1 Jóhann B. Guðmundsson 2008-05-28 14:47:54 EDT
Created attachment 306970 [details]
yum-output.log
Comment 2 Seth Vidal 2008-05-30 12:41:29 EDT
Do you have any existing broken deps in your rpmdb?

rpm -Va --nofiles --nomd5
Comment 3 Jóhann B. Guðmundsson 2008-06-02 03:40:55 EDT
The rpm -Va --nofiles --nomd5 command displayed nothing + I also ran yum clean
all and did rpm --rebuilddb.. then I did again yum update --skip-broken and it
failed again but then I checked to see if I could reduce the -x packages and and
now yum is happy updating with just --skip-broken -x gmime-sharp..

Packages skipped because of dependency problem: 
gmime-2.2.21-1.fc10.i386 from rawhide
gtk-sharp2-2.12.0-2.fc10.i386 from rawhide
mono-addins-0.3.1-2.fc10.i386 from rawhide
Comment 4 Yanko Kaneti 2008-06-27 14:55:49 EDT
This bug is quite evident with more disruptive library updates like todays 
gnutls soname bump.
rpm -Va --nofiles --nomd5    shows nothing here.
This on both a i386 and x86_64 systems.
Comment 5 John Poelstra 2008-10-15 17:44:11 EDT
This bug has been triaged

Is this still an issue with latest rawhide?
Comment 6 Jóhann B. Guðmundsson 2008-10-16 05:21:56 EDT
Well I think you need to have special circumstances as in 
like in this case gmime-sharp needs to have broken dependency 
to be able to triage it.  

But I think you can just close. 
So far --skip-broken as it should.

Any reason that --skip-broken ain't enabled by default 
as in each time an update is run it's run with the --skip-broken
switch enabled hence the user could at least update something instead
of failing on dependency's ?
Comment 7 Tim Lauridsen 2008-11-01 05:36:00 EDT
This should be fixed in the current version of yum in rawhide.
I will close this for now, please open a new report if you detect any problems in then future.

Note You need to log in before you can comment on or make changes to this bug.