Bug 448786 - PassSync doesn't use the LDAP Password Modify Extended Operation
PassSync doesn't use the LDAP Password Modify Extended Operation
Status: CLOSED DEFERRED
Product: 389
Classification: Community
Component: Sync Service (Show other bugs)
1.1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks: 389_1.3.0 512820 690316
  Show dependency treegraph
 
Reported: 2008-05-28 15:52 EDT by Loris Santamaria
Modified: 2015-11-19 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 17:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Loris Santamaria 2008-05-28 15:52:33 EDT
Description of problem:

PassSync does a ldapmodify on the userPassword attribute on FDS. So an optional
password change plugin on FDS, like ipa-pwd-extop, never gets triggered
  
Actual results:

Only the userPassword attribute is changed on FDS 

Expected results:

UserPassword, samba hashes and krbPrincipalKey should get modified when using a
password change plugin like ipa-pwd-extop


Additional info:
Comment 1 Rich Megginson 2009-04-09 13:16:05 EDT
This falls under the category of RFC correctness
Comment 3 Martin Kosek 2012-01-04 08:45:04 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/122
Comment 4 Noriko Hosoi 2015-11-19 17:22:30 EST
Closing this bug since we moved to the ticket system:
https://fedorahosted.org/389/ticket/122

Note You need to log in before you can comment on or make changes to this bug.