Bug 448788 - LANG="" repodiff can create unicode errors
LANG="" repodiff can create unicode errors
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 15:57 EDT by Jesse Keating
Modified: 2013-01-09 22:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 15:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-05-28 15:57:21 EDT
LANG="" repodiff
--old=file:///mnt/koji/mash/rawhide-20080527/development/source/SRPMS/
--new=file:///mnt/koji/mash/rawhide-20080528/development/source/SRPMS/

kdeutils-4.0.80-1.fc10
----------------------
* Mon May 26 18:00:00 2008 Than Ngo <than@redhat.com> 4.0.80-1
- 4.1 beta1


Traceback (most recent call last):
  File "/usr/bin/repodiff", line 227, in <module>
    main(sys.argv[1:])
  File "/usr/bin/repodiff", line 211, in main
    print msg
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf8' in position
236: ordinal not in range(128)

Calling it with LANG=en_US works.  This comes about because cron doesn't set a
LANG when it runs, so anytime repodiff is ran via cron you can get a traceback.
Comment 1 Tim Lauridsen 2008-05-29 07:09:40 EDT
Jesse, please test if this one is working better.

http://devel.linux.duke.edu/gitweb/?p=yum-utils.git;a=blob_plain;f=repodiff.py;hb=9f23ddc1681ef1b9cc74a97fa90f5c76f3d3c00f
Comment 2 Jesse Keating 2008-05-29 10:54:02 EDT
As stated on list, forcing LANG=C is probably a bad thing here.
Comment 5 Tim Lauridsen 2008-06-03 06:50:58 EDT
Jesse, just let me know, if the latest version work for you.
Comment 6 Jesse Keating 2008-06-03 13:46:55 EDT
Yes, the revision in comment #4 works.
Comment 7 Tim Lauridsen 2008-06-03 15:07:54 EDT
thanks, i will put out a new yum-utils version soon including this one

Note You need to log in before you can comment on or make changes to this bug.