Bug 448826 - openib-perftest and perftest have an obsolete loop
openib-perftest and perftest have an obsolete loop
Status: CLOSED DUPLICATE of bug 448772
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perftest (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Doug Ledford
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 17:20 EDT by James Antill
Modified: 2014-01-21 01:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 11:28:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-05-28 17:20:31 EDT
Description of problem:
 openib-perftest and perftest obsolete each other, without any versioning
informatiion.
 This causes a whole bunch of problems, like "yum update" will continue forever
installing the other package ... the worst of which is that "yum install
perftest" doesn't work.
 The sane fix is to remove the obsolete from one of them (and make the other
version specific, i.e. in perftest Obsoletes: openib-perftest <= 1.2-5.el5_1.1).

Version-Release number of selected component (if applicable):

openib-perftest.i386                     1.2-6.el5_1.1
perftest.i386                            1.2-10.el5 

Additional info:

 I've done a patch against the 5.2.z yum which "fixes" the biggest problem
(recursion traceback so you can't install either):

http://people.redhat.com/jantill/yum/patches/yum-obs-loops-install.patch

...but all the others are basically unfixable, in that there's no "right"
behaviour that yum can guess correctly.
Comment 1 Doug Ledford 2008-05-29 11:28:17 EDT

*** This bug has been marked as a duplicate of 448772 ***

Note You need to log in before you can comment on or make changes to this bug.