Bug 448834 - freenx-server problems on FC9
freenx-server problems on FC9
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: freenx-server (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 18:19 EDT by Jan Andrejkovic
Modified: 2008-06-14 02:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 02:31:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Andrejkovic 2008-05-28 18:19:07 EDT
Description of problem:

Sorry guys but I have the feeling freenx-server is completely broken in FC9.
Those problem can put out many people from using freenx...

Version-Release number of selected component (if applicable):
nx-3.2.0-27.fc9.i386
freenx-server-0.7.2-8.fc9.x86_64

How reproducible:

Steps to Reproduce:
1. su nx
2. login
(enter username and password of the local user)
3. startsession  --link="isdn" --backingstore="1" --streaming="1" --nodelay="1"
--encryption="1" --cache="32M" --images="128M" --shmem="1" --shpix="1"
--strict="0" --composite="1" --media="0" --session="mysession"
--type="unix-gnome" --geometry="1024x768" --client="winnt"
--keyboard="pc102/en_US" --screeninfo="1024x768x32+render" 

Actual results:
NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 700 Session id: localhost-2000-yyyyyyyyyyyyyyyyyyyyyy
NX> 705 Session display: 2000
NX> 703 Session type: unix-gnome
NX> 701 Proxy cookie: xxxxxx
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: xxxxxx
NX> 704 Session cache: unix-gnome
NX> 707 SSL tunneling: 1
/usr/libexec/nx/nxserver: line 1368:  7567 Terminated              sleep
$AGENT_STARTUP_TIMEOUT
NX> 105 NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set
SESSION_LOG_CLEAN=0 in node.conf and investigate
"/home/user/.nx/F-C-localhost-2000-yyyyyyyyyyyyyyyyyyyyyy/session". You might
also want to try: ssh -X myserver; /usr/libexec/nx/nxnode --agent to test the
basic functionality. Session log follows:
Can't open /var/lib/nxserver/db/running/sessionId{yyyyyyyyyyyyyyyyyyyyyy}: No
such file or directory.
mv: cannot stat
`/var/lib/nxserver/db/running/sessionId{yyyyyyyyyyyyyyyyyyyyyy}': No such file
or directory
NX> 1006 Session status: closed
NX> 1001 Bye.

Expected results:
Package should be opened without error and Session should be opened.

Additional info:
wiki says that in case of this error freenx should be reinstalled. I reinstalled
it and I deleted all old configs and files but no luck...

I enabled SESSION_LOG_CLEAN=0 in /etc/nxserver/node.conf

And in the ~user/.nx/F-C-xxx/session I saw:

/usr/libexec/nx/nxagent: error while loading shared libraries: libXcomp.so.3:
cannot open shared object file: No such file or directory

After that I copied files from /usr/lib/nx into /usr/lib but I did not overwrite
any existing files.

After that the error displayed in ~user/.nx/F-C-xxx/session is:

Info: Agent running with pid '10055'.
Session: Starting session at 'Wed May 28 22:58:59 2008'.
Error: Aborting session with 'Unable to open display
'nx/nx,options=/home/jandrejkovic/.nx/C-xxxx/options:2000''.
Session: Aborting session at 'Wed May 28 22:58:59 2008'.
Session: Session aborted at 'Wed May 28 22:58:59 2008'.

Do you have any hint what should be the next step and can somebody fix
freenx-server packages?
Comment 1 Sander Hoentjen 2008-06-13 14:01:59 EDT
to add to these problems, when trying to install freenx-server on x86_64 i get:
Error: Missing Dependency: /usr/lib64/nx is needed by package
freenx-server-0.7.2-8.fc9.x86_64 (updates)
Comment 2 Axel Thimm 2008-06-14 02:31:24 EDT
(In reply to comment #0)
> /usr/libexec/nx/nxagent: error while loading shared libraries: libXcomp.so.3:
> cannot open shared object file: No such file or directory

The problem is that nx ships some libraries that are augmented/expanded versions
of the ones Fedora ships, but are also not 100% compatible.

Therefore these libs need to be dormant in normal usage. The solution was to get
them out of the way and only used them upon demand with LD_* variable settings.

I don't see any better solution at this point. You can check bugzilla for old
issues (when this separation wasn't done 100% clean) to better understand why we
can't make the nx replacements visible to ldconfig.

Note You need to log in before you can comment on or make changes to this bug.