This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 448840 - avc when restarting network
avc when restarting network
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 19:48 EDT by John Poelstra
Modified: 2008-06-20 06:33 EDT (History)
0 users

See Also:
Fixed In Version: selinux-policy-3.3.1-57.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-20 06:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2008-05-28 19:48:43 EDT
Description of problem:
as root: 'service network restart'


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.3.1-51.fc9.noarch

How reproducible:
100%


Summary:

SELinux is preventing ps (dhcpc_t) "sys_nice" to <Unknown> (dhcpc_t).

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by ps. It is not expected that this access is
required by ps and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:system_r:dhcpc_t:s0
Target Context                unconfined_u:system_r:dhcpc_t:s0
Target Objects                None [ capability ]
Source                        ps
Source Path                   /bin/ps
Port                          <Unknown>
Host                          yardsale
Source RPM Packages           procps-3.2.7-20.fc9
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-51.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     yardsale
Platform                      Linux yardsale 2.6.25.3-18.fc9.i686 #1 SMP Tue May
                              13 05:38:53 EDT 2008 i686 i686
Alert Count                   2
First Seen                    Wed 28 May 2008 04:41:19 PM PDT
Last Seen                     Wed 28 May 2008 04:42:03 PM PDT
Local ID                      0e3b05b7-a125-4930-b176-cabfdb207899
Line Numbers                  

Raw Audit Messages            

host=yardsale type=AVC msg=audit(1212018123.460:120): avc:  denied  { sys_nice }
for  pid=10778 comm="ps" capability=23 scontext=unconfined_u:system_r:dhcpc_t:s0
tcontext=unconfined_u:system_r:dhcpc_t:s0 tclass=capability

host=yardsale type=SYSCALL msg=audit(1212018123.460:120): arch=40000003
syscall=3 success=yes exit=197 a0=5 a1=7de960 a2=3ff a3=7de900 items=0
ppid=10777 pid=10778 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0
fsgid=0 tty=pts1 ses=10 comm="ps" exe="/bin/ps"
subj=unconfined_u:system_r:dhcpc_t:s0 key=(null)
Comment 1 Daniel Walsh 2008-05-29 08:43:57 EDT
You can allow this for now.

# audit2allow -M mypol -l -i /var/log/audit/audit.log
# semodule -i mypol.pp

Fixed in selinux-policy-3.3.1-57.fc9.noarch

Note You need to log in before you can comment on or make changes to this bug.