Bug 448844 - rss-glx will not run correctly in the kde screensaver conf, no mini preview of the screensavers nor running full screen
rss-glx will not run correctly in the kde screensaver conf, no mini preview o...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rss-glx (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-28 20:47 EDT by ryan f
Modified: 2008-07-01 01:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.8.1.p-20.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-01 01:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ryan f 2008-05-28 20:47:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
in the kde screensaver configuration dialog all of the rss-glx entries appear and can be configured but they never run, the mini preview screen is blank as is the fullscreen preview. 

i suspect the possibility that kde is looking in the wrong location/filename for the executable files since they are all named rss-glx-<name> which was not always the case in previous releases.

Version-Release number of selected component (if applicable):
rss-glx-0.8.1.p-17.fc8, rss-glx-kde-0.8.1.p-17.fc8

How reproducible:
Always


Steps to Reproduce:
1. install rss-glx-kde and rss-glx
2. open configure desktop->screensaves
3. attempt to use screensaver by clicking and attempting to preview

Actual Results:
nothing, black preview

Expected Results:
screensaver should have run in mini preview and fullscreen preview

Additional info:
have not tested in standard screensaver mode but i have no reason to suspect that it would run.
Comment 1 Rex Dieter 2008-05-28 21:42:18 EDT
The fix will probably need to happen in rss-glx
Comment 2 Rex Dieter 2008-05-28 21:42:40 EDT
Fwiw, last I checked, these all worked for me. ??
Comment 3 Mary Ellen Foster 2008-05-29 04:04:41 EDT
Actually, I think the issue is in the -kde package. If you look at the .desktop
files, they say things like
    Exec=biof
whereas the executables in rss are more like
    /usr/bin/rss-glx-biof

So probably all of the -kde .desktop files need to be edited to add the rss-
prefix to the executable.
Comment 4 Nils Philippsen 2008-05-29 06:09:27 EDT
rss-glx-0.8.1.p-20 which contains a fix for this problem is building for F7, F8,
F9, Rawhide.
Comment 5 Fedora Update System 2008-05-29 06:46:58 EDT
rss-glx-0.8.1.p-20.fc9 has been submitted as an update for Fedora 9
Comment 6 Fedora Update System 2008-05-29 06:46:59 EDT
rss-glx-0.8.1.p-20.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-05-29 06:47:01 EDT
rss-glx-0.8.1.p-20.fc7 has been submitted as an update for Fedora 7
Comment 8 Fedora Update System 2008-05-30 22:10:06 EDT
rss-glx-0.8.1.p-20.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rss-glx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4656
Comment 9 Fedora Update System 2008-07-01 01:28:00 EDT
rss-glx-0.8.1.p-20.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-07-01 01:28:58 EDT
rss-glx-0.8.1.p-20.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.