Bug 448888 - service bluetooth does not support chkconfig
service bluetooth does not support chkconfig
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
: 449789 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 06:05 EDT by Jóhann B. Guðmundsson
Modified: 2013-01-09 23:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 05:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-05-29 06:05:44 EDT
Description of problem:

Got the Summary when updating to rawhide 29/05/2008



Version-Release number of selected component (if applicable):



How reproducible:

Always

Steps to Reproduce:
1. Update to rawhide
2.
3.
  
Actual results:

Error msg in yum's update process

Expected results:

No error msg
Additional info:
Comment 1 Kris Rusocki 2008-06-08 20:27:56 EDT
Seeing something somewhat similar in Fedora 9.

After installation, /etc/rc?.d/*bluetooth got '-1' priorities
[e.g. K-1bluetooth, S-1bluetooth].


jackal 18:25 [755]:~$ grep -c chkconfig: /etc/init.d/bluetooth 
0
jackal 18:25 [756]:~$ 


Comment 2 Kris Rusocki 2008-06-08 20:29:22 EDT
Just wondering if that's intended...


Thanks,
Krzysztof
Comment 3 Jeremy Katz 2008-07-09 15:58:47 EDT
*** Bug 449789 has been marked as a duplicate of this bug. ***
Comment 4 Matthias Clasen 2008-08-23 23:00:09 EDT
Bastien, can you take care of this ?
Comment 5 Matthias Haase 2008-08-26 13:53:01 EDT
/etc/init.d/bluetooth has - unfortunately - an undefined chkconfig!

In result, bluetooth service does start always before messagebus...
(fc9 with all updates on a Thinkpad T40)

hicd requires running messagebus otherwise bluetooth service fails to start.

# chkconfig: 345 23 85
on top of /etc/init.d/bluetooth fixes wrong startup of this service.
It starts now after messagebus with right order...

There are several bug reports related to this...
Comment 6 Bastien Nocera 2008-09-12 06:28:31 EDT
Fixed in rawhide in bluez-4.5-1.fc10. Update pushed for F9.
Comment 7 Fedora Update System 2008-09-14 02:50:07 EDT
bluez-utils-3.35-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluez-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7239
Comment 8 Jesse Keating 2008-10-03 19:41:46 EDT
This is fixed for F10, removing it from the blocker, leaving the bug open for the F9 update.
Comment 9 Fedora Update System 2008-10-07 05:48:25 EDT
bluez-utils-3.35-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.