Bug 448904 - rshd fails when running on kernel without AUDIT support
rshd fails when running on kernel without AUDIT support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rsh (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 09:08 EDT by Pete Wyckoff
Modified: 2013-04-30 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 08:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Wyckoff 2008-05-29 09:08:20 EDT
rshd refuses all logins when audit is not enabled in the kernel
rsh-server-0.17-50.fc9.x86_64.  Build and boot a new kernel
without CONFIG_AUDIT, or disable it at boot.
Use rsh from another machine; with .rhosts access for instance.
Instead of a shell prompt, rshd sends back the string
"Error sending audit event." and rsh exits.
It looks like this happens due to the patch netkit-rsh-0.17-audit.patch
where calls to audit_log_acct_message() via log_audit() will
fail with -ECONNREFUSED.  Instead, rshd should notice this error
and continue with login in spite of the missing audit logging system.
Comment 1 Adam Tkac 2008-10-03 08:15:04 EDT
fixed in rawhide rsh-0.17-51.fc10. I'm not going to fix this problem in F9. If you think this issue should be fixed in F9 as well, please reopen.

Note You need to log in before you can comment on or make changes to this bug.