Bug 448961 - gpk-updat-viewer crashes on viewing update details
gpk-updat-viewer crashes on viewing update details
Status: CLOSED DUPLICATE of bug 447347
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 14:26 EDT by Mathieu Bridon
Modified: 2008-05-30 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 05:08:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log obtained with -v option (59.23 KB, application/octet-stream)
2008-05-29 14:26 EDT, Mathieu Bridon
no flags Details

  None (edit)
Description Mathieu Bridon 2008-05-29 14:26:25 EDT
Description of problem:
The notification icon appeared, telling me updates were available. I clicked on
"review" to check what was to be updated. I checked the details for each
application to update with success, except for the one which is yum. When
clicking on the "yum" package, gpk-update-viewer crashed.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.12-13.20080516.fc9.x86_64

How reproducible:
Always, but only for this particular package.

Steps to Reproduce:
1. review updates
2. click on the yum package => crash
3. the notification icon remains, and I can do it again
  
Actual results:
the update viewer crashes

Expected results:
it should display the yum package update details.

Additional info:
Here is the list of available updates in gpk-update-viewer:
- audit{,-libs-libs-python}
- beagle{,-epiphany}
- cronie
- empathy{,-libs-python}
- enchant
- gdb
- gedit
- glx-utils
- gstreamer-plugins-{base,farsight,good}
- gtkhtml3
- gtk-sharp2
- java-1.6.0-openjdk(-plugin)
- kvm
- mesa-libGL(-devel)
- mesa-libGLU(-devel)
- perl (with lots of perl libs)
- python-urlgrabber
- rhythmbox
- selinux-policy{,-targeted}
- shared-mime-info
- sound-juicer
- stunnel
- telepathy-{gabble,glib}
- totem-pl-parser
- tzdata{,-java}
- yum


I attached the result of $ gkp-update-viewer -v.

I didn't apply any of the updates in case you would want more informations.
Comment 1 Mathieu Bridon 2008-05-29 14:26:25 EDT
Created attachment 307119 [details]
log obtained with -v option
Comment 2 Richard Hughes 2008-05-29 16:16:28 EDT
Can you try updating just PackageKit and gnome-packagekit first, then trying
again please? Thanks.
Comment 3 Mathieu Bridon 2008-05-29 19:19:38 EDT
I do not have any update for PackageKit or gnome-packagekit, so I enabled the
updates-testing repo and saw there were.

Using yum --changelog, I found out this update corrected the bug 447347 (which I
hadn't found as its status is "ON_QA", which is not selected by default in the
bugzilla search).

Seems exactly like what I have, so I updated it.

Now the issue is fixed.

Sorry about that, next time I'll select all status while searching for a bug :)
Comment 4 Richard Hughes 2008-05-30 05:08:53 EDT
Cool, thanks.

*** This bug has been marked as a duplicate of 447347 ***

Note You need to log in before you can comment on or make changes to this bug.