Bug 448964 - libmikmod crashes on many tracker files
libmikmod crashes on many tracker files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mikmod (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 14:34 EDT by Andrew Zabolotny
Modified: 2008-05-29 17:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 16:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small sample which crashes mpd+mikmod 3.2.0 but doesn't crash 3.1.11 (41.11 KB, audio/x-it)
2008-05-29 14:34 EDT, Andrew Zabolotny
no flags Details

  None (edit)
Description Andrew Zabolotny 2008-05-29 14:34:03 EDT
Description of problem:
When using mpd from livna repository with libmikmod.so.3 it crashes on many files.

Version-Release number of selected component (if applicable):
mpd-0.13.1-2.lvn9.x86_64
libmikmod-3.2.0-3.beta2.fc9.x86_64
mikmod-3.2.2-8.beta1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Put the attached .it file into the mpd music directory, and back up your
music database.
2. Run mpd manually: mpd --create-db --no-daemon --stdout --verbose
  
Actual results:
explore: found: v-child.it (v-child.it)
Segmentation fault

Additional info:
I downgraded to mikmod/mpd from Fedora 8 and it works with the same files
absolutely fine. Maybe the decision to upgrade from libmikmod 3.1.11 to
3.2.0beta2 was not too good. The guys from MPD team are even saying they
sometimes want to remove MikMod support from MPD as the latest MikMod is very
buggy and they get lots of complains like mine.

I made a .spec file which builds libmikmod 3.1.11 as separate rpm, and then have
built latest mpd from livna9 against it, and it works fine.

So it looks like mikmod 3.2.0 is definitely buggy. I'm not sure it's going to
progress anywhere (looks like 3.2.0 was released in 2005) perhaps it would make
sense to downgrade to 3.1.11.
Comment 1 Andrew Zabolotny 2008-05-29 14:34:03 EDT
Created attachment 307120 [details]
Small sample  which crashes mpd+mikmod 3.2.0 but doesn't crash 3.1.11
Comment 2 Hans de Goede 2008-05-29 16:30:52 EDT
(In reply to comment #0)
> Description of problem:
> When using mpd from livna repository with libmikmod.so.3 it crashes on many files.
> 
> Version-Release number of selected component (if applicable):
> mpd-0.13.1-2.lvn9.x86_64
> libmikmod-3.2.0-3.beta2.fc9.x86_64
> mikmod-3.2.2-8.beta1.fc9.x86_64
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. Put the attached .it file into the mpd music directory, and back up your
> music database.
> 2. Run mpd manually: mpd --create-db --no-daemon --stdout --verbose
>   
> Actual results:
> explore: found: v-child.it (v-child.it)
> Segmentation fault
> 
> Additional info:
> I downgraded to mikmod/mpd from Fedora 8 and it works with the same files
> absolutely fine. Maybe the decision to upgrade from libmikmod 3.1.11 to
> 3.2.0beta2 was not too good.

That is a bit pf jumping to conclusions, there aren't that mich differences
between 3.1.11 and 3.2.0beta2, only a few small (but worth it) improvements.
I've done a full audit of all differences between the 2 versions before deciding
to update to 3.2.0beta2.

> The guys from MPD team are even saying they
> sometimes want to remove MikMod support from MPD as the latest MikMod is very
> buggy and they get lots of complains like mine.
> 

The latest mikmod is _not_ buggy, _their_ code using it is buggy, and if they
would have spend the time they apparently spend complaining about this debugging
the issue, the issue would have been long fixed.

> So it looks like mikmod 3.2.0 is definitely buggy. I'm not sure it's going to
> progress anywhere (looks like 3.2.0 was released in 2005) perhaps it would make
> sense to downgrade to 3.1.11.

Again jumping to (uneducated) conclusions. But don't believe me on my words,
believe me on my deeds, I've filed a bugreport against mpd in livna:
http://bugzilla.livna.org/show_bug.cgi?id=1987

Which has a patch against mpd attached fixing this. Since you seem to be in
close contact with the MDP devs, I'm sure they will appreciate you forwarding
the patch, fixing _their_ long lasting problems with the libmikmod 3.2.0beta.

Comment 3 Andrew Zabolotny 2008-05-29 17:51:49 EDT
Thank you very much and sorry if I was a bit harsh :)

Note You need to log in before you can comment on or make changes to this bug.