Bug 448980 - ONBOOT=yes does not work with Bridge with no ports
ONBOOT=yes does not work with Bridge with no ports
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 15:07 EDT by Anthony Liguori
Modified: 2014-03-16 23:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 12:27:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Liguori 2008-05-29 15:07:35 EDT
Description of problem:

There is a check in /etc/init.d/network to that skips ifcfg- scripts if they are
of TYPE=Bridge.  Presumably, this is because bridges are brought up
automatically if an interface that is bridged by that bridge is brought up.

It is perfectly reasonable to define a bridge with no interfaces bridged.  For
instance, this is common when using virtualization when creating private
networks.  Right now, there doesn't seem to be a way to bring up a bridge with
no ports at boot time.

Version-Release number of selected component (if applicable):

initscripts-8.76.2-1

How reproducible:


Steps to Reproduce:
1. Create a bridge in /etc/sysconfig/network-scripts/ifcfg-br0
2. Set ONBOOT=yes
3. Do not bridge any physical interfaces to br0
  
Actual results:

After booting, ifconfig br0 fails because br0 has not been brought up.

Expected results:

After booting, br0 should have been brought up.

Additional info:
Comment 1 iarly selbir 2009-03-22 15:15:15 EDT
is this problem happening yet?

Thanks for any reply.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bill Nottingham 2009-03-23 12:27:31 EDT
I've tested this on Fedora 10 - it works there.

Note You need to log in before you can comment on or make changes to this bug.