Bug 449013 - Sort by last updated doesn't sort correctly
Sort by last updated doesn't sort correctly
Status: CLOSED NOTABUG
Product: Issue-Tracker
Classification: Retired
Component: User Interface (Show other bugs)
GovernanceBoard
All All
medium Severity low
: ---
: ---
Assigned To: Lisa Lu
: Reopened
: 455526 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 17:24 EDT by Mike Amburn
Modified: 2009-10-26 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 10:53:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of behaviour (81.21 KB, image/png)
2008-05-29 17:24 EDT, Mike Amburn
no flags Details

  None (edit)
Description Mike Amburn 2008-05-29 17:24:21 EDT
Sort by last updated doesn't sort correctly.
(see attachment)
Comment 1 Mike Amburn 2008-05-29 17:24:22 EDT
Created attachment 307139 [details]
Screenshot of behaviour
Comment 2 Mike Amburn 2009-01-30 12:11:37 EST
Steps to reproduce:
- View tickets list
- Click column header for Last Updated

Tickets are not sorted correctly in normal or "reverse" mode.

url patterns:
&sort=modified
&sort=modified&reverse=true
Comment 3 Mike Amburn 2009-01-30 12:11:57 EST
*** Bug 455526 has been marked as a duplicate of this bug. ***
Comment 4 Lisa Lu 2009-03-10 12:04:35 EDT
Tom,

In the screen shot provided, it's a behavior for base groups. There are two separate queries for sorting columns.
  - sort tickets with "Registered" status. "Registered" means a customer has opened a new ticket. And it requires Red Hat's attention...

  - sort tickets with non-Registered status. They are tickets in working progress.

The reason there are two separate queries was because GSS wanted tickets with Registered status to always stop on top of the list. 

If you go to an escalation queue, for instance, [Support Engineering Group], you don't see this behavior because they are a list of issues in working progress.

Could you please double check with GSS before we make the code change?

Thanks,
Lisa
Comment 5 Tom Mirc 2009-03-10 14:34:02 EDT
2:15 PM Checked with Sarah Wang and Brent Fox of GSS.  

[Brent] Nobody on my team has complained to me about the current behavior.

[Brent] From my perspective, I can see the logic in wanting the "Registered"
issues to appear at the top so that they don't get lost in the shuffle.  
In other words, a ticket should only be in "Registered" status for as
short a time as possible.

----------------------------

Awaiting additional discussion from Sarah.  Lisa, at this point it is advisable to hold off on any more coding on this ticket until further word comes from Sarah.  

--Tom
Comment 6 Tom Mirc 2009-03-10 14:43:01 EDT
2:22 PM [Brent Fox] My preference would be to leave things as-is, unless Sarah has some objection.

Tom to mark ticket as closed.
Comment 7 Tom Mirc 2009-03-10 18:08:34 EDT
[Sarah Wang] 4:37 PM

Can the bugzilla be updated to address the true requirement as described
by Mike? sort by date, sort by status with Registered on top. It would
be great if this can be worked into the current backlog.

[Mike Amburn] Mike Amburn wrote:

Actually, when I was managing Issue-Tracker requests, I consistently
received "bug reports" about this "feature" in that it breaks the
expected functionality, which is the ability to sort by date.

I understand the need to have "Registered" issues appear at the top.
However, that functionality should be provided by sorting by status.
If we need to tweak sorting by status so that "Registered" appears at
the top and "On Hold" etc. appears at the bottom, we could enhance
usability of both.

Bottom line is that the interface appears broken, regardless of the
fact that we've intentionally broken it. 

[Tom Mirc] to reopen bug with new requirements
Comment 8 Tom Mirc 2009-03-18 10:53:13 EDT
The new requirement is to enforce sorting by category.  

Registered will always appear at the top of the queue, sorted chronologically.  

Waiting on Tech appears after Registered, sorted chronologically. 

Waiting on Customer appears after Waiting on Tech, sorted chronologically.  

Long-Term appears last.
Comment 9 Tom Mirc 2009-03-18 17:03:15 EDT
[Mike Amburn] 
Today, each group can select the statuses it wants to use (stored in  
groups_statuses). 

If we could add the ability for groups to order this  
list as they desire, this attribute could be used not only to sort the  
statuses in the status picklist (Registered at top, Closed at the  
bottom) but also sort tickets. 

By moving out of hard-code and into a configuration, IT has less to manage.
Comment 10 Lisa Lu 2009-03-19 11:12:46 EDT
per Alex, moving the bug back to GovernanceBoard.

Lisa
Comment 12 Lisa Lu 2009-09-30 10:53:59 EDT
Per Nicky's comment, I'm closing the bug.

thanks,
Lisa

Note You need to log in before you can comment on or make changes to this bug.