Bug 449039 - password server issues with 3.2.0-1.rc1.14.fc9
password server issues with 3.2.0-1.rc1.14.fc9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On: 449038
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 19:32 EDT by Orion Poplawski
Modified: 2008-07-03 05:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.2.0-2.17.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 05:33:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 5502 None None None Never

  None (edit)
Description Orion Poplawski 2008-05-29 19:32:04 EDT
Description of problem:

Just upgrading to F9 (was working fine with same config on F8), saw password
server issues so decided to grab the latest samba.  Still see them (windows XP
client):

[2008/05/29 17:27:18,  1] auth/auth_server.c:check_smbserver_security(294)
  password server 8 is plaintext, but we are encrypted. This just can't work :-(

The 8 above appears to be random text and changes from message to message.

Version-Release number of selected component (if applicable):
3.2.0-1.rc1.14.fc9

How reproducible:
every time.

password server (earth) is CentOS 5 running samba-3.0.28a.
Comment 1 Orion Poplawski 2008-05-29 19:54:09 EDT
With 1.pre3.9 I get:

[2008/05/29 17:52:24,  1] auth/auth_server.c:check_smbserver_security(288)
  password server is not connected (cli not initilised)
Comment 2 Guenther Deschner 2008-05-30 07:11:26 EDT
Can you check if the rpms from
http://koji.fedoraproject.org/koji/taskinfo?taskID=636117 work for you ? These
incorporate 779a3af0cd3ecbf82e3de16a4e0aec046c19d869 from the samba git repo.
Comment 3 Fedora Update System 2008-05-30 10:29:15 EDT
samba-3.2.0-1.rc1.15.fc9 has been submitted as an update for Fedora 9
Comment 4 Orion Poplawski 2008-05-30 11:26:34 EDT
That fixes the connection issue.  As noted upstream I now get:

[2008/05/30 09:20:02,  1] librpc/ndr/ndr.c:ndr_pull_error(467)
  ndr_pull_error(11): ndr_pull_advance by 503316478 failed
[2008/05/30 09:20:02,  1] librpc/ndr/ndr.c:ndr_pull_error(467)
  ndr_pull_error(11): Pull bytes 2
[2008/05/30 09:20:02,  0] rpc_server/srv_pipe.c:api_rpcTNP(2326)
  api_rpcTNP: srvsvc: SRVSVC_NETSHAREENUMALL failed.

but things seems to work.  
Comment 5 Orion Poplawski 2008-05-30 11:43:58 EDT
I just had to say thank you so much for fixing this so fast.  I was wondering
all evening what I was going to do today to deal with this, but lo and behold a
fix was waiting for me when I got in to work.  Huzzah!
Comment 6 Fedora Update System 2008-06-03 03:30:47 EDT
samba-3.2.0-1.rc1.15.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update samba'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4856
Comment 7 Fedora Update System 2008-06-09 23:12:43 EDT
samba-3.2.0-1.rc1.15.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.