Bug 449056 - yum multilib_policy problems
yum multilib_policy problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-29 23:31 EDT by Joshua Jensen
Modified: 2014-01-21 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.2.17-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 22:11:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.conf with the multilib_policy=all (286 bytes, text/plain)
2008-05-30 14:45 EDT, Joshua Jensen
no flags Details

  None (edit)
Description Joshua Jensen 2008-05-29 23:31:36 EDT
Description of problem:

Fedora 9 x86_64 with yum-3.2.16-2.fc9.noarch

"yum install libflashsupport" only wants to install the x86_64 version of
libflashsupport.  This is a change in yum's behavior, but I remember reading
about multilib_policy.  So I add "multilib_policy=all" to yum.conf... and not
change in yum's behaviour.  Huh?  So I make yum.conf say "multilib_policy=best"
and still no change.

The only way I can get the .i386 version of libflashsupport installed is by
calling it out:  yum install libflashsupport.i386

Is multilib_policy=best hardcoded, regardless of what the config file says? 
What I though "=all" was supposed to be the default... but that it could be
changed for people who were annoyed by that... it seems neither is the case.
Comment 1 seth vidal 2008-05-30 00:21:20 EDT
can you post your yum.conf for multilib_policy=all - I just want to make sure
it's all spelled right.

and then could you run yum install libflashsupport and post the output?

thanks
Comment 2 Seth Vidal 2008-05-30 12:42:56 EDT
gotten a second confirmation on this one.
Comment 3 Joshua Jensen 2008-05-30 14:45:51 EDT
Created attachment 307228 [details]
yum.conf with the multilib_policy=all
Comment 4 Joshua Jensen 2008-05-30 14:48:00 EDT
Attached.  I doubt I misspelled it as I cut and pasted it from the man page:

Here is the output even with multilib_policy=all explicitly set:


$ sudo yum -d1 install libflashsupport

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 libflashsupport         x86_64     000-0.5.svn20070904  fedora            8.7 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 8.7 k
Is this ok [y/N]: 
Comment 5 James Antill 2008-05-31 17:12:06 EDT
 Here's the fix:

diff --git a/yum/__init__.py b/yum/__init__.py
index 72f9091..c621a73 100644
--- a/yum/__init__.py
+++ b/yum/__init__.py
@@ -2187,7 +2187,7 @@ class YumBase(depsolve.Depsolve):
                            
                            pkgs = use
                            
-                pkgs = packagesNewestByName(pkgs)
+                pkgs = packagesNewestByNameArch(pkgs)
 
                 pkgbyname = {}
                 for pkg in pkgs:

...it'll be in the nesxt Fed-9 update. Upstream commit
f6317aabb2734357311b6103286a76054c3cd0e9
Comment 6 Joshua Jensen 2008-06-18 18:58:21 EDT
Still not fixed... at least not in yum-3.2.16-2.fc9.noarch.  What yum update is
this in?
Comment 7 Fedora Update System 2008-07-09 10:51:23 EDT
yum-3.2.17-1.fc9 has been submitted as an update for Fedora 9
Comment 8 Fedora Update System 2008-07-09 17:50:59 EDT
yum-3.2.17-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6301
Comment 9 Joshua Jensen 2008-07-09 18:28:24 EDT
Better, but still doesn't work.  Explicitly setting multilib_policy=all now at
least works with yum-3.2.17-1.fc9 ... but the default behaviour when it isn't
set at all is still the implicit "best" arch.

I believe that this isn't the intended behaviour... all past versions of yum I
can remember installs with the "all" assumption unless "best" is manually set.
Comment 10 Seth Vidal 2008-07-09 21:14:27 EDT
Joshua, in F9 we changed the default so yum will only install the best arch not
both.

But it is an option so you can change it.

Comment 11 Joshua Jensen 2008-07-10 14:21:05 EDT
Ah... ok.  So "best" is intentionally the default.  I don't know that I like
that, but that is a far different issue than this bug, where multilib_policy=all
wasn't even working.

Ok then... lets close this out as fixed.  Thanks Seth.
Comment 12 Fedora Update System 2008-07-22 13:28:28 EDT
yum-3.2.17-2.fc8 has been submitted as an update for Fedora 8
Comment 13 Fedora Update System 2008-07-23 22:10:58 EDT
yum-3.2.17-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-08-07 13:16:47 EDT
yum-3.2.18-1.fc8 has been submitted as an update for Fedora 8
Comment 15 Fedora Update System 2008-08-27 14:02:22 EDT
yum-3.2.19-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/yum-3.2.19-1.fc8
Comment 16 Fedora Update System 2008-09-10 02:58:49 EDT
yum-3.2.19-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.