Bug 449063 - Deskbar Applet doesn't support Firefox 3 (beta 5)
Deskbar Applet doesn't support Firefox 3 (beta 5)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: deskbar-applet (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 01:02 EDT by Rafael F.
Modified: 2016-09-19 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 15:22:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot (83.02 KB, image/png)
2008-05-30 01:05 EDT, Rafael F.
no flags Details

  None (edit)
Description Rafael F. 2008-05-30 01:02:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
Deskbar applet is not compatible with Mozilla Firefox 3 beta 5 (which is shipped by default on Fedora 9). It complaints that it is not a compatible version and doesn't do web search or bookmark suggestions. However since Firefox is my default browser and mail application in Gnome (I configured it so that it will handle mailto links with Gmail's web interface) if I write a full email adress and hit enter Firefox will open as intended.

Version-Release number of selected component (if applicable):
deskbar-applet-2.22.0.1-1.fc9.i386 

How reproducible:
Always


Steps to Reproduce:
1.Install Deskbar Applet
2.Install Firefox 3
3.Try to do a web search from the applet

Actual Results:
The web search appears in the extensions with errors tab and obviously the applet can't search the web. It doesn't suggest any bookmarks either. It simply doesn't work with Firefox 3. It used to work on Fedora 8, which shipped Firefox 2

Expected Results:
The applet should have suggested a web search or any matching bookmarks when text is entered

Additional info:
I'm posting a screen-shot where I highlight some additional info that the applet displays. It says "Firefox version must be between 2.0.0.0 and 3.0.0.0. I don't know if that has anything to do with the fact that Mozilla changed version naming to 3 numbers, so version 3 will be 3.0.0 and not 3.0.0.0
Comment 1 Rafael F. 2008-05-30 01:05:18 EDT
Created attachment 307160 [details]
screen-shot
Comment 2 Luke Macken 2008-11-21 15:22:03 EST
This is an upstream limitation, and not a bug.  It is mentioned on the deskbar homepage that the bookmark search only works in Firefox 2.

Note You need to log in before you can comment on or make changes to this bug.