Bug 449085 - Printing selection produces invalid Postscript file
Printing selection produces invalid Postscript file
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 07:04 EDT by Martin Jürgens
Modified: 2018-04-11 04:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 11:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of non-reproduction (43.74 KB, image/png)
2008-05-30 07:32 EDT, Matěj Cepl
no flags Details
Postscript produced by the Print (selection) command (49.38 KB, application/postscript)
2008-05-30 08:34 EDT, Matěj Cepl
no flags Details
picture of default tab, where "selection" is greyed out (204.06 KB, image/png)
2008-05-30 09:03 EDT, Martin Jürgens
no flags Details
another attempt to reproduce (1.67 KB, application/postscript)
2008-05-30 17:25 EDT, Matěj Cepl
no flags Details
another attempt -- this time with proportional fonts (67.02 KB, application/postscript)
2008-05-30 17:30 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Martin Jürgens 2008-05-30 07:04:01 EDT
Description of problem:
It is not possible to print a selection with current Firefox in Fedora 9.

Version-Release number of selected component (if applicable):
firefox-3.0-0.60.beta5.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open a webpage
2. Select some text
3. Press File -> Print
  
Actual results:
The option "Selection" is greyed out

Expected results:
Option "SelectioN" selectable

Additional info:
Comment 1 Matěj Cepl 2008-05-30 07:32:21 EDT
Created attachment 307187 [details]
screenshot of non-reproduction
Comment 2 Matěj Cepl 2008-05-30 08:34:34 EDT
Created attachment 307192 [details]
Postscript produced by the Print (selection) command

Although I cannot reproduce the issue as described by the reporter, printing
selection doesn't produce valid Postscript for me.
Comment 3 Matěj Cepl 2008-05-30 08:36:06 EDT
The attached Postscript when run through ghostscript (from the package
ghostscript-8.62-3.fc9.i386) crashes:

[matej@viklef ~]$ gs mozilla.ps
GPL Ghostscript 8.62 (2008-02-29)
Copyright (C) 2008 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Error: /limitcheck in --show--
Operand stack:
   (")
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1905   1   3   %oparray_pop   1904
  1   3   %oparray_pop   1888   1   3   %oparray_pop   1771   1   3  
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   %array_continue
Dictionary stack:
   --dict:1146/1684(ro)(G)--   --dict:0/20(G)--   --dict:99/200(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 50220
GPL Ghostscript 8.62: Unrecoverable error, exit code 1
[matej@viklef ~]$ 
Comment 4 Tim Waugh 2008-05-30 08:53:10 EDT
Matej: I can't reproduce that from the attachment in comment #2.  I get no
errors, just some badly cropped text in a single line near the top.
Comment 5 Martin Jürgens 2008-05-30 09:03:05 EDT
Created attachment 307194 [details]
picture of default tab, where "selection" is greyed out

Matej, hi :)

While I have an option to "Print Selection Only" in the "Options" tab, in the
default dialog, it is greyed out. See attached file.
Comment 6 Carl Worth 2008-05-30 12:11:58 EDT
(In reply to comment #2)
> Created an attachment (id=307192) [edit]
> Postscript produced by the Print (selection) command
> 
> Although I cannot reproduce the issue as described by the reporter, printing
> selection doesn't produce valid Postscript for me.

Matej,

Are your packages up to date? That PostScript file has:

      %%Creator: cairo 1.5.12 (http://cairographics.org)

Cairo version 1.5.12 has lots of known bugs with its PostScript output.
These are fixed in cairo 1.6.4 which firefox should be using in Fedora 9,
(as far as I understand things).

If you can't get a cairo-1.6.4-generated PostScript file then there's a
problem. And if you can, but it's still broken, then that's another problem,
but one I will be very interested in hearing more about.

-Carl
Comment 7 Matěj Cepl 2008-05-30 17:25:45 EDT
Created attachment 307239 [details]
another attempt to reproduce

Urgh, apparently upstream binary happened again (I hate like it is not possible
-- or it is inconvenient to run two binaries of firefox at once).

OK, this time it is cairo 1.6.4 and it is completely blank again. Carl, isn't
this the same issue as that RHEL 4.7 one?
Comment 8 Matěj Cepl 2008-05-30 17:30:10 EDT
Created attachment 307240 [details]
another attempt -- this time with proportional fonts

Hmm, there is apparently a difference when only non-proportional fonts are
selected (previous postscript), and only proportional fonts are (this
attachment). Still broken and incomplete, but we are getting there.
Comment 9 Martin Jürgens 2008-05-30 17:55:56 EDT
Just a short notice, when I use that option in the "Options" tab of the printing
dialog, I experience the same problem, my system is up to date. Matej, did you
have a look at my screenshot and can you reproduce that, also? "Auswahl" on the
screenshot means "Selection" in English.
Comment 10 Martin Stransky 2008-10-23 11:10:14 EDT
Seems to be fixed in the latest fedora package (3.0.2)...

Note You need to log in before you can comment on or make changes to this bug.