Bug 449094 - r8169 ethernet stopped working kernel-2.6.25.3-18.fc9.x86_64
r8169 ethernet stopped working kernel-2.6.25.3-18.fc9.x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 08:06 EDT by Neal Becker
Modified: 2008-11-19 09:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:55:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-05-30 08:06:21 EDT
Description of problem:
My wired r8169 stopped working.  The driver is loaded - I don't see any
errors.  tcpdump reports nothing (except my own dhcp requests). NM won't
connect.

Booted 2.6.25-14.fc9.x86_64.  Works.

I have repeated this several times.

One thing I don't understand - I'm sure r8169 has been working for me for
quite a while after that last kernel update.

One thing - I DID get a bunch of yum updates last night - but none seem to
be relevant.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Snyder 2008-06-24 16:52:16 EDT
FYI, it is also broken in RHEL 5.2 kernel 2.6.18-92.1.1.el5, and in the previous
2.6.18-92.el5 kernel as well

Revert to the 2.6.18-53.1.21.el5 kernel and all is well.
Comment 2 Robert Barnett 2008-09-04 18:27:53 EDT
I've just seen this problem with the r8169 driver on a new ACER laptop. The problem went away by temporarily turning acpi=off.

We ran yum update to the latest kernel and now everything is fine.
Comment 3 Josep 2008-09-21 18:02:51 EDT
This could be a duplicate of Bug #444966.

Could you check whether doing a "rmmod r8169; modprobe r8169" makes the device come up?
Comment 4 Neal Becker 2008-09-21 19:22:34 EDT
I no longer have this problem.  Not sure what made the difference.
Comment 5 Chuck Ebbert 2008-09-22 13:02:04 EDT
Is this fixed in 2.6.26.3-29?
Comment 6 Neal Becker 2008-09-22 13:41:09 EDT
I am not seeing the problem in 2.6.26.3-29 (not sure how many versions back it was fixed)
Comment 7 Fedora Update System 2008-11-05 20:51:23 EST
kernel-2.6.27.4-26.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.4-26.fc9
Comment 8 Fedora Update System 2008-11-06 21:56:34 EST
kernel-2.6.27.4-26.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9467
Comment 9 Fedora Update System 2008-11-10 08:16:01 EST
kernel-2.6.27.5-32.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.5-32.fc9
Comment 10 Fedora Update System 2008-11-11 21:58:02 EST
kernel-2.6.27.5-32.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9583
Comment 11 Fedora Update System 2008-11-13 02:43:10 EST
kernel-2.6.27.5-37.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.5-37.fc9
Comment 12 Fedora Update System 2008-11-14 06:54:27 EST
kernel-2.6.27.5-41.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.27.5-41.fc9
Comment 13 Fedora Update System 2008-11-19 09:54:52 EST
kernel-2.6.27.5-41.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.