Bug 449097 - [NetApp 5.3 bug] multipathd holds the mounted logical volmes open on restart
[NetApp 5.3 bug] multipathd holds the mounted logical volmes open on restart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ben Marzinski
Cluster QE
: OtherQA
Depends On:
Blocks: 373081
  Show dependency treegraph
 
Reported: 2008-05-30 08:19 EDT by Rajashekhar M A
Modified: 2010-10-22 21:35 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:08:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Terminal logs - has multipath.conf and lvdisplay outputs. (3.44 KB, text/plain)
2008-05-30 08:19 EDT, Rajashekhar M A
no flags Details

  None (edit)
Description Rajashekhar M A 2008-05-30 08:19:03 EDT
Description of problem:

On RHEL 5.2 host, when multipathd is restarted, with some logical volumes
mounted, the daemon holds the mounted lvs open. As a result, the open count does
not reduce to zero even after we unmount the LVs and the LVs are not in use.

Version-Release number of selected component (if applicable):

OS: RHEL 5.2 GA

# rpm -qa  | grep device
device-mapper-1.02.24-1.el5
device-mapper-multipath-0.4.7-17.el5
device-mapper-event-1.02.24-1.el5
device-mapper-1.02.24-1.el5
#

How reproducible:
Always

Steps to Reproduce:

1. Create a logical volume on a few LUNs.
2. Create a file system on the lv and mount it to a mountpiont.
3. Check lvdisplay output - should display open count as 1.
4. Restart the multipathd daemon.
5. Unmount the lv from the mountpoint.
6. Check the output of lvdisplay.

Actual results:

The open count is still shown as 1 since the multipathd now holds it.

Expected results:

The multipathd should not hold it open.

Additional info:

1. We hit this issue if we add the automount entry in the /etc/fstab and reboot
the machine. After the machine is booted, we unmount the lv from its mount
point. Now, if we check the open count using lvdisplay, the count is still 1.

Open count reduces to zero after restarting the daemon with the lv unmounted.
The daemon holds only the mounted LVs open.

2. I have attached a file which has terminal logs.
Comment 1 Rajashekhar M A 2008-05-30 08:19:03 EDT
Created attachment 307191 [details]
Terminal logs - has multipath.conf and lvdisplay outputs.
Comment 3 Ben Marzinski 2008-09-12 19:54:01 EDT
In order to deal with root device failures, multipathd creates its own namespace, and copies all the necessary callout functions to a ramfs.  However this was creating duplicate mounts in the new namespace for every device that was mounted when multipathd started, which would only get cleaned up when multipathd stopped.  Multipathd now unmounts all of the unneeded mounts from its own namespace on startup.
Comment 6 Naveen Reddy 2008-10-29 12:12:30 EDT
I have verified this in RHEL5.3 Beta and the open count is shown correctly.
This issue is fixed.

Thank you
Naveen
Comment 9 errata-xmlrpc 2009-01-20 17:08:55 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0232.html

Note You need to log in before you can comment on or make changes to this bug.