Bug 449107 - gdm doesn't use ~/.dmrc for Other.. users
gdm doesn't use ~/.dmrc for Other.. users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 09:34 EDT by derrien
Modified: 2015-01-14 18:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 13:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 577756 None None None Never

  None (edit)
Description derrien 2008-05-30 09:34:51 EDT
Description of problem:
When Others.. is selected the ~/.dmrc of the user seems not used. Isn'it
possible to read the .dmrc between username and password and to use it ?

And how to empty the list of users listed by gdm ?

Version-Release number of selected component (if applicable):
gdm-2.22.0-5.fc9.i386

How reproducible:


Steps to Reproduce:
1.Select Other...
2.
3.
  
Actual results:
connexion use the defaults language and session type

Expected results:
connexion use the ~/.dmrc if it exists

Additional info:
Comment 1 derrien 2008-12-04 12:26:35 EST
Same thing with Fedora 10. So with the disable_user_list option, users must always select their Language and Sessions if they don't use the defaults...
Comment 2 Jayson King 2008-12-09 19:37:10 EST
(In reply to comment #0)
> And how to empty the list of users listed by gdm ?

See bug 433649 comment 21
Comment 3 Andrew McNabb 2009-02-18 11:50:09 EST
I've had the same problem with Fedora 9 and Fedora 10.  Let me know if there's anything I should try.
Comment 4 Andrew McNabb 2009-04-02 14:53:14 EDT
I tried Fedora 11 Beta, and I'm pretty sure this bug had not been fixed.  This has been stagnating for a long time, so I just added an upstream bug on GNOME's bugzilla (#577756).
Comment 5 Andrew McNabb 2009-04-15 11:16:06 EDT
It looks like gdm-2.26.0-7 included a patch to fix this.  I'll try to test it soon.
Comment 6 Andrew McNabb 2009-04-15 11:45:08 EDT
I can confirm that gdm-2.26.0-7 fixes the problem.
Comment 7 Ray Strode [halfline] 2009-04-15 13:04:33 EDT
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.