This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 449113 - Firefox 3 fsync excessively and ui freezes
Firefox 3 fsync excessively and ui freezes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.2
All Linux
medium Severity high
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 10:16 EDT by Jeff Bastian
Modified: 2010-10-22 21:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 09:55:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 421482 None None None Never

  None (edit)
Description Jeff Bastian 2008-05-30 10:16:33 EDT
+++ This bug was initially created as a clone of Bug #439908 +++

Description of problem:
Firefox 3 uses sqlite for storage of information like history, bookmarks, etc.
They used to use async i/o, but ran into corruption issues. So they went with
sync i/o which blocks very easily.

Sqlite runs six fsyncs per transaction for history changes. History changes
happen ever time you go to a new page. If you are doing something else on the
system like say a kernel compile, virtual machine image creation, or anything
i/o intensive then the Firefox gui freezes, because it is waiting on the fsync
to finish. I have seen this take literally a minute. Someone in the upstream bug
documented this taking 30 seconds.

The change was introduced in Firefox 3 beta 3. Before then it was async i/o.

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta5.6.el5

How reproducible:
Always

Steps to Reproduce:
1. Install Firefox
2. Start Firefox
3. Do something i/o intensive
4. Load new pages
  
Actual results:
Firefox's ui freezes completely till the fsync completes

Expected results:
Firefox's ui doesn't freeze

Additional info:
The Mozilla developers have said they doesn't consider this a big issue, but for
me it makes Firefox 3 unusable. They have also said they don't plan to fix it
till after the 3.0 release, maybe not till 3.1.
Comment 2 Matěj Cepl 2008-05-30 11:15:23 EDT
We are following the bug in the upstream bugzilla no. 421482 very carefully, and
it is most likely that any relevant patch will be applied.

*** This bug has been marked as a duplicate of 439908 ***
Comment 3 Jeff Bastian 2008-05-30 11:24:14 EDT
Re-opening bug.  This BZ is for RHEL 5 tracking.  Bug 439908 is for Fedora rawhide.
Comment 4 Matěj Cepl 2008-05-30 11:25:13 EDT
Yes, sorry, I missed that IssueTracker number. Will fix.
Comment 6 RHEL Product and Program Management 2008-06-02 15:56:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Martin Stransky 2008-07-18 09:55:56 EDT
Should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.