Bug 449123 - re-compile of source rpm fails
re-compile of source rpm fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 12:04 EDT by Matthias Haase
Modified: 2008-06-10 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 11:18:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild-log.txt (179.60 KB, text/plain)
2008-06-06 11:57 EDT, Matthias Haase
no flags Details

  None (edit)
Description Matthias Haase 2008-05-30 12:04:18 EDT
Description of problem:
Re-compile of source rpm failed.


Version-Release number of selected component (if applicable):
compiz-0.7.2-3.fc9.src.rpm

How reproducible:
Always reproducible

Steps to Reproduce:
1. rpmbuild --rebuild --target=i686 --sign compiz-0.7.2-3.fc9.src.rpm 
2.
3.
  
Actual results:
Compile fails because kdecoration_p.h and kdecoration_plugins_p.h are missed.

Expected results:
Re-compile without errors about missed header files.

Additional info:

"g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include -I/usr/include/dbus-1.0
-I/usr/lib/dbus-1.0/include   -I/usr/lib/qt-3.3/include -I/usr/include/kde 
-I/home/endur/tmp/rpm/compiz-0.7.2-3.fc9-root-endur/usr/include  -O3
-falign-functions=4 -fomit-frame-pointer -funroll-loops -mfancy-math-387 -pipe
-march=i686 -mtune=i686 -Wall -D_FORTIFY_SOURCE=2 -MT window.moc.o -MD -MP -MF
.deps/window.moc.Tpo -c -o window.moc.o window.moc.cpp"


"In file included from window.moc.cpp:11:
window.h:27:27: error: kdecoration_p.h: No such file or directory"

"In file included from window.h:37,
                 from window.moc.cpp:11:
options.h:27:25: error: kdecoration.h: No such file or directory"

"In file included from decorator.moc.cpp:11:
decorator.h:37:35: error: kdecoration_plugins_p.h: No such file or directory
decorator.h:38:27: error: kdecoration_p.h: No such file or directory"

# locate kdecoration

/home/endur/tmp/rpm/BUILD/compiz-0.7.2/kde/window-decorator-kde4/kdecoration_plugins.cpp
/home/endur/tmp/rpm/BUILD/compiz-0.7.2/kde/window-decorator-kde4/kdecoration_plugins.h
/home/endur/tmp/rpm/BUILD/compiz-0.7.2/kde/window-decorator-kde4/.deps/kdecoration_plugins.Po
/usr/include/kde4/kdecoration.h
/usr/include/kde4/kdecorationbridge.h
/usr/include/kde4/kdecorationfactory.h
/usr/lib/libkdecorations.so.4
/usr/lib/libkdecorations.so.4.0.4
/usr/lib/kde4/devel/libkdecorations.so

kdecoration.h is /usr/include/kde4/, but this file couldn't be found.


I can't find any source package for Fedora 9 which contains kdecoration_p.h or
kdecoration_plugins_p.h.
Comment 1 Matěj Cepl 2008-06-06 11:38:12 EDT
Could you please attach here complete log of the attempt to build? I.e., run

rpmbuild --rebuild --target=i686 --sign compiz-0.7.2-3.fc9.src.rpm \
    >rpmbuild-log.txt 2>&1

and then attach rpmbuild-log.txt to this bug.

Thank you.
Comment 2 Matthias Haase 2008-06-06 11:57:46 EDT
Created attachment 308547 [details]
rpmbuild-log.txt
Comment 3 Matthias Haase 2008-06-10 07:48:45 EDT
Same error after an update to latest kdebase3-3.5.9-15, kdelibs3-3.5.9-15
*-devel. I have compared local installed packages to the one of fedora mock
build... Don't understand why the build there doesn't fails...
I think the .configure.in detects some obsolete header files for kde4...
Comment 4 Adel Gadllah 2008-06-10 11:18:03 EDT
I fixed this in rawhide.
The problem is that configure finds the kde3-libs and try to build against them.
The fix is to pass --disable-kde to configure. The result is that only the kde4
libs are used. This does not happen in the buildsys because the kde3 packages
are not in the buildroot.
The fixed configure looks like this (you can do this to continue building it in F9):
--------------------
%configure 					\
	--enable-gconf 			 \
	--enable-dbus 				\
	--enable-place 			\
	--enable-librsvg 			\
	--enable-gtk 				\
	--enable-metacity 			\
	--enable-gnome				\
	--with-default-plugins=%{plugins}	\
	--enable-gnome-keybindings		\
	--disable-kde				\
	--enable-kde4
-----------------
Comment 5 Matthias Haase 2008-06-10 11:31:44 EDT
o.k. as I understand this was a missed configure option of the specfile. Sounds
good. I'll rebuild.

Note You need to log in before you can comment on or make changes to this bug.