Bug 44913 - Upgrade fails and results in duplicate packages in rpm database
Upgrade fails and results in duplicate packages in rpm database
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-18 16:12 EDT by Steve Tate
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tate 2001-06-18 16:12:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
I just upgraded from RH 6.2 to RH 7.1, and while the upgrade went smoothly
for the most part, I noticed that afterwards there were *two* sendmail
packages installed -- the old one was still there along with the new one. 
In other words:

    [root@marvin upgrade]# rpm -q -a | grep sendmail-8
    sendmail-8.11.2-14
    sendmail-8.9.3-20

Looking back at the upgrade log, I found this sequence of messages:

    Upgrading sendmail.
    /bin/linuxconf: error while loading shared libraries: libncurses.so.4:
cannot load shared object file: No such file or directory
    /etc/aliases created as /etc/aliases.rpmnew

    /etc/sendmail.cf saved as /etc/sendmail.cf.rpmsave

    execution of %trigger scriptlet from linuxconf-1.17r2-6 failed, exit
status 127

In fact, the same thing happened with the apache package -- similar
messages in the log, and duplicate packages in the rpm database.  Finally,
even though it wasn't upgraded as part of the installer/upgrade, I've also
got duplicate "faq" and "howto" packages.  Perhaps this is a bug in rpm
rather than anaconda?


How reproducible:
Didn't try

Steps to Reproduce:
1.  I really don't want to go through an entire upgrade again!?!
2.
3.
	

Additional info:
Comment 1 Brent Fox 2001-06-21 15:40:14 EDT
Changing component to RPM.
Comment 2 Jeff Johnson 2001-06-30 15:19:51 EDT
This is actually a packaging bug, in linuxconf AFAICT, which
should have had a
	Requires: libncurses.so.4
that prevented that library soname from being removed, which
caused unexpected scriptlet failure, which leads to duplicate
entries in the rpmdb.

Off to linuxconf for further analysis, bounce back to rpm if
you still think it's an rpm "bug" ...
Comment 3 Brent Fox 2002-06-05 12:10:21 EDT
Closing because we don't ship linuxconf anymore
Comment 4 Red Hat Bugzilla 2006-02-21 13:48:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.