Bug 449138 - Unable to apply patches generated by gendiff
Unable to apply patches generated by gendiff
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 14:18 EDT by Jesse Keating
Modified: 2013-01-09 22:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 16:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 235692 None None None Never

  None (edit)
Description Jesse Keating 2008-05-30 14:18:34 EDT
I'm not able to use the team menu item to apply patches that were generated by
gendiff.  The problem is that gendiff references a source file that doesn't
exactly exist in the source tree.

When using gendiff, you copy the original source file(s) to the same name but
with a different extension, foo -> foo.jk.  Then you modify the original file,
and then you'd call 'gendiff path/ .jk' and it will diff all the files that end
with '.jk' against the original file names to generate a patch.  The patch winds
up referencing that source '.jk' file and comparing it to the actual file in
your project space.  Eclipse balks on this because it can't find the source
file.  Patch will happily apply it.
Comment 1 Andrew Overholt 2008-06-04 16:01:21 EDT
I filed this upstream as:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=235692

Note You need to log in before you can comment on or make changes to this bug.