Bug 449141 - sudo slow with init level 3
sudo slow with init level 3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sudo (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Kopeček
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 14:37 EDT by Meryll Larkin
Modified: 2010-11-09 08:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 08:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sudo.log as per request (119.30 KB, text/plain)
2009-02-10 21:15 EST, Meryll Larkin
no flags Details

  None (edit)
Description Meryll Larkin 2008-05-30 14:37:38 EDT
Description of problem:
Starting at init level 3, login as username; startx get Gnome desktop, open
terminal, sudo su -   
Wait half a minute before user is converted to root.  This time delay only
happens to the specific user who is logged in pre-GUI, and at the console.  Does
not have time delay for sudo through an ssh terminal nor for other users.

Version-Release number of selected component (if applicable):
RHE5.1, RHE5.2

How reproducible:
see above

Steps to Reproduce:
1.  Boot to initlevel 3.  Login as any user with account on machine
2.  startx open GUI (in my case, Gnome)
3.  Open terminal
4.  sudo su -   (yes, this user has sudo su - privileges)
5.  wait 30 seconds before prompt returns with user being root
  
Actual results:
wait 30 seconds before prompt returns with user being root

Expected results:
less than 30 seconds

Additional info:
Does not have time delay for sudo through an ssh terminal nor for other users.

Not a critical bug because functionality is not effected, just a time delay.  I
was puzzled by this for months and finally figured out that if I login using
init level 5; sudo speeds up to less than a second.  sudo must be going through
more steps when user logs in at init level 3 and then starts GUI?
Comment 1 Meryll Larkin 2008-05-30 14:58:49 EDT
possibly not a bug and by design?
Comment 2 Daniel Kopeček 2009-02-03 07:45:26 EST
Could you please attach the output of "strace -r -osudo.log sudo su -" ?
You'll have to set u+s on /usr/bin/strace to be able to run the above command. And don't forget to unset it afterwards :]
Comment 3 Meryll Larkin 2009-02-10 21:15:20 EST
Created attachment 331507 [details]
sudo.log as per request
Comment 4 Daniel Kopeček 2009-08-20 07:31:29 EDT
Maybe this is the same problem as in bug #498749. Please try the solution mentioned there.
Comment 7 Steve Grubb 2010-07-21 10:50:40 EDT
Is this problem the same as bug #498749?
Comment 8 Daniel Kopeček 2010-08-31 08:29:50 EDT
Closing this bug because there's no response from the reporter and it seems that this isn't a bug in sudo.

Note You need to log in before you can comment on or make changes to this bug.