Bug 449164 - Issues with newer chkconfig
Issues with newer chkconfig
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: chkconfig (Show other bugs)
4.4
i386 Linux
low Severity low
: rc
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 16:19 EDT by Tuc
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 18:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Header of every S* in rc3.d (17.30 KB, text/plain)
2008-05-30 16:19 EDT, Tuc
no flags Details

  None (edit)
Description Tuc 2008-05-30 16:19:01 EDT
Description of problem:

I previously reported this in 444410, but since it isn't the same platform it
was put into a new ticket.

LONG drawn out story, but maybe it'll help.

Actually running on a Centos 4.4 platform. We ran into an issue where we
ABSOLUTELY needed the functionality of a newer bind. Because I am directed to
ONLY use RPMs for system based things, I found the bind-9.4.2-3.fc7.src.rpm from  
Atkac. I understood it wasn't really for RHEL4 and Centos, I planned on cleaning
up anywhere it put things that weren't normal for Centos. In the midst of trying
to install, it said that a newer version of chkconfig was necessary. I found
"chkconfig-1.3.37-2.src.rpm" and thought that it was just an update of the
program, it shouldn't change how things operate.

We recently had to reboot the system, and found that it attempted to run RADIUS
before MYSQL, which didn't work so well. It appears to place S88radiusd (As per
solely chkconfig settings in /etc/rc.d/init.d/radiusd) before S99mysql (Its
chkconfig has "2345 64 36", but it also contains a LSB Init script. The only
other script that contains an LSB Init script is boinc (345 98 03). As such,
both end up in S99, and oddly when you resetpriorities on either, it recreates
the other (mysql->boinc, boinc->mysql)

I've attempted to resetpriorities on NetworkManager, no such change.

Version-Release number of selected component (if applicable):

[root@ports init.d]# uname -a
Linux ports.example.com 2.6.9-42.0.10.EL #1 Tue Feb 27 09:24:42 EST 2007 i686
i686 i386 GNU/Linux

[root@ports init.d]# chkconfig -v
chkconfig version 1.3.37

[root@ports init.d]# more /etc/issue
CentOS release 4.4 (Final)
Kernel \r on an \m

Unfortunately the backups don't go back far enough to be able to use the
previous version of chkconfig, so I do not have a binary to test if the previous
behaviour is any different.


How reproducible:

(See above)

Steps to Reproduce:

(Above)
  
Actual results:


Expected results:

Not sure what the proper expectation is since I'm not sure how chkconfig and the
LSB block interact.

Additional info:

I could just mv S99mysql to S65mysql, but any time the chkconfig is run again
(Upgrade, etc) it would putit back to S99mysql)

Attaching headers from every S* in rc3.d
Comment 1 Tuc 2008-05-30 16:19:01 EDT
Created attachment 307236 [details]
Header of every S* in rc3.d
Comment 2 Bill Nottingham 2008-05-30 16:43:52 EDT
What happens if you remove NetworkManager entirely and resetpriorities?
Comment 3 Tuc 2008-05-30 17:06:04 EDT
The following:

1) When I resetpriorities on mysql, it becomes S64mysql, and ONLY that changes
2) When I resetpriorities subsequently on boinc, it becomes S98boinc, and ONLY
that appears to change.

NetworkManager is also not running it appears and there is no PID file.

Yum claims NetworkManager 0.3.1-3 is installed. In reading the documentation on
it I don't see any reason we would ever use NetworkManager on this machine. Its
a server with a static IP. 
Comment 4 Bill Nottingham 2008-05-30 18:52:55 EDT
OK.

An alternative solution would be to install NetworkManager-0.3.1-4.el4, which
should no longer provide $network. In any case, it's more or less 'working as
designed'

Note You need to log in before you can comment on or make changes to this bug.