Bug 449166 - [regression] Running xfs breaks metacity, nautilus and applets
Summary: [regression] Running xfs breaks metacity, nautilus and applets
Status: CLOSED DUPLICATE of bug 430416
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xfs
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-05-30 20:31 UTC by Pavel Polischouk
Modified: 2018-04-11 13:36 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-06-06 16:15:49 UTC


Attachments (Terms of Use)

Description Pavel Polischouk 2008-05-30 20:31:02 UTC
Description of problem:

When X server is configured to accept fonts both from local font directories as
well as xfs running on localhost, gnome desktop fails to start properly:
metacity, nautilus and some gnome applets refuse to run. The following error is
reported by all of them (with minor variations):

Window manager warning: xserver doesn't have 'fixed' font.
Bug in window manager: Unexpected X error: BadName (named color or font does not
exist) serial 209 error_code 15 request_code 45 minor_code 0)

Version-Release number of selected component (if applicable):

xorg-x11-xfs-1.0.5-2.fc9

Installed fonts:
culmus-fonts-0.101-4.fc8.noarch
bitmap-fonts-0.3-5.2.fc9.noarch
fonts-KOI8-R-75dpi-1.0-10.fc8.noarch
taipeifonts-1.2-5.fc9.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch
fonts-chinese-3.03-12.fc8.noarch
kacst-fonts-1.6.2-2.fc8.noarch
liberation-fonts-1.0-4.fc9.noarch
xorg-x11-fonts-misc-7.2-6.fc9.noarch
texlive-texmf-fonts-2007-22.fc9.noarch
texlive-texmf-errata-fonts-2007-4.fc9.noarch
tv-fonts-1.1-5.fc9.noarch
dejavu-lgc-fonts-2.24-3.fc9.noarch
bitstream-vera-fonts-1.10-8.noarch
xorg-x11-fonts-cyrillic-7.2-6.fc9.noarch
fonts-hebrew-0.101-2.fc8.noarch
ghostscript-fonts-5.50-18.fc8.noarch
cjkunifonts-ukai-0.1.20060928-4.fc8.noarch
fonts-arabic-2.1-2.fc8.noarch
urw-fonts-2.4-5.fc9.noarch
xorg-x11-fonts-truetype-7.2-3.fc8.noarch
fonts-KOI8-R-1.0-10.fc8.noarch
paktype-fonts-2.0-2.fc8.noarch
fonts-KOI8-R-100dpi-1.0-10.fc8.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
VLGothic-fonts-20071215-2.fc9.noarch
sazanami-fonts-mincho-0.20040629-4.20061016.fc8.noarch
sazanami-fonts-gothic-0.20040629-4.20061016.fc8.noarch
fonts-japanese-0.20061016-13.fc9.noarch
cjkunifonts-uming-0.1.20060928-4.fc8.noarch

How reproducible:

If xfs is running before logging into Gnome desktop, always. Reproduced on 2
machines (i386 and x86_64).
If xfs is restarted after the gnome desktop is up, all the failing apps and
applets can load again.
If xfs is not running at all, the problem doesn't happen.

Steps to Reproduce:
1. Start XFS
2. Log in to Gnome
  
Actual results:
No window manager, no nautilus desktop, some applets missing.
No xfs - no problem.

Expected results:
Desktop should show up properly

Additional info:
Regression: the same setup worked fine with F8.
This might be an X Server bug rather than xfs bug, selecting xfs as a target
because there's an obvious workaround to restart or stop xfs.

Comment 1 Matěj Cepl 2008-06-06 16:15:49 UTC

*** This bug has been marked as a duplicate of 430416 ***

Comment 2 Nerijus Baliūnas 2008-06-09 20:04:44 UTC
Why was it marked as a duplicate? Please see
https://bugzilla.redhat.com/show_bug.cgi?id=430416#c30 - Pete Zaitcev explicitly
stated that he doesn't care if the bug is fixed in F9, and bug 430416 is for
rawhide.


Note You need to log in before you can comment on or make changes to this bug.