Bug 449170 - F9 out of the box doesn't allow ssh authorized keys
F9 out of the box doesn't allow ssh authorized keys
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 16:50 EDT by Joshua Jensen
Modified: 2008-06-22 06:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-22 06:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2008-05-30 16:50:47 EDT
Description of problem:

Fresh F9 x86_64 install... all updates as of May 29th... and I can't ssh to the
box with ssh keys.  Huh?

Here are the raw selinux messages:

Raw Audit Messages            

host=f9.mydomain.org type=AVC msg=audit(1212179791.687:852): avc:  denied  {
search } for  pid=29712 comm="sshd" name="joshua" dev=dm-3 ino=917505
scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023
tcontext=system_u:object_r:file_t:s0 tclass=dir

host=f9.mydomain.org type=SYSCALL msg=audit(1212179791.687:852): arch=c000003e
syscall=4 success=no exit=-13 a0=7ffffc5877d0 a1=7ffffc587740 a2=7ffffc587740
a3=8101010101010100 items=0 ppid=29711 pid=29712 auid=500 uid=500 gid=500
euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=pts2 ses=60
comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023
key=(null)

Surely this isn't the intention of the default rules out of the box?
Comment 1 Joshua Jensen 2008-06-18 19:01:19 EDT
Surely this is a large problem.  SSH keys don't work out of the box?  Hello?!!!
Comment 2 Daniel Walsh 2008-06-22 06:28:24 EDT
Some how you have a mislabeled file system.  file_t indicates that no label has
been applied to a file.  sshd seems to be on a file system separate from the one
you installed.  If you run restorecon on the file system it should fix the labels.

restorecon -R -v /home for example.

If you have a more serious problem, and you need to fix the labeling on the
entire system you can execute

touch /.autorelabel
reboot

Note You need to log in before you can comment on or make changes to this bug.