Bug 449174 - RFE: allow customization of daemon env. using /etc/sysconfig/nrpe
RFE: allow customization of daemon env. using /etc/sysconfig/nrpe
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nrpe (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 17:43 EDT by David Mansfield
Modified: 2009-02-24 16:00 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.12-6.fc10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 15:54:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for nrpe sysv init script to allow env. customization (524 bytes, patch)
2008-05-30 17:43 EDT, David Mansfield
no flags Details | Diff
patch for nrpe sysv init script to allow env. customization (418 bytes, patch)
2008-05-30 17:45 EDT, David Mansfield
no flags Details | Diff

  None (edit)
Description David Mansfield 2008-05-30 17:43:25 EDT
the attached patch against nrpe 2.7 source adds the standard functionality of
sourcing the /etc/sysconfig/nrpe file to read a customized daemon environment. 
without this, it's impossible to run plugins which need any environment variables.

this is done in dozens of init scripts, and hopefully here too.

the patch has been submitted (today) upstream to the nagios-devel list, and i
can report progress in that via this bug.

i'm NOT attached a patch to the spec file because it is too trivial (not that
this patch isn't really trivial too)!
Comment 1 David Mansfield 2008-05-30 17:43:25 EDT
Created attachment 307241 [details]
patch for nrpe sysv init script to allow env. customization
Comment 2 David Mansfield 2008-05-30 17:44:35 EDT
Comment on attachment 307241 [details]
patch for nrpe sysv init script to allow env. customization

oops.  attached wrong patch (this one was for rpmforge package)
Comment 3 David Mansfield 2008-05-30 17:45:32 EDT
Created attachment 307242 [details]
patch for nrpe sysv init script to allow env. customization
Comment 4 Peter Lemenkov 2009-01-30 10:43:37 EST
Hello!

I modified David's patch slightly - my one adds ability to enable/disable ssl via /etc/sysconfig/nrpe:

http://peter.fedorapeople.org/nrpe/

BTW I'm interested in adding this feaure for EPEL as well - it doesn't break anything, and I tired to add "-n" to /etc/init.d/nrpe after each update :) (not so often, but still painful)
Comment 5 Fedora Update System 2009-02-04 21:10:42 EST
nrpe-2.12-6.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update nrpe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-1231
Comment 6 Fedora Update System 2009-02-04 21:22:29 EST
nrpe-2.12-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nrpe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1365
Comment 7 David Mansfield 2009-02-05 09:34:28 EST
yes. if we could PLEASE have this in the EPEL also, that would be great.  I feel like that's where I originally wanted this in the first place but somehow it landed on fedora... which is good, too.
Comment 8 Fedora Update System 2009-02-24 15:54:00 EST
nrpe-2.12-6.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-02-24 16:00:06 EST
nrpe-2.12-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.