Bug 449188 - Firefox incorrectly detects another running instance
Firefox incorrectly detects another running instance
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 20:19 EDT by Tethys
Modified: 2008-10-30 05:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 05:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 462311 None None None Never

  None (edit)
Description Tethys 2008-05-30 20:19:23 EDT
Description of problem:
Firefox won't start due to a claim that it's already running. It brings up a
dialog box, saying:

Firefox is already running, but is not responding. To open a new window, you
must first close the existing Firefox process, or restart your system.

The only problem is that there isn't an existing firefox process on that box.
However, there is a running firefox on another box, and my home directory is NFS
mounted, and hence shared between the two. I can't believe this behaviour is
intentional. After all, it's been possible to run two instances of a browser on
multiple boxen pretty much since the dawn of the web. It's quite a regression
that we're unable to do so now...

Version-Release number of selected component (if applicable):
firefox-3.0-0.60.beta5.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. NFS mount your home directory on two boxen
2. Start firefox on the first box
3. Attempt to start firefox on the second box
Comment 1 Martin Stransky 2008-10-29 05:53:52 EDT
If you want to run two independent instances of the browser in the same home, create a different profile for each box. It's not a bug, it's intentional because of the session management.
Comment 2 Tethys 2008-10-30 04:58:08 EDT
Wrong. Maybe Firefox has made such braindead design decisions. But the bug
still stands. Firefox *is* still incorrectly detecting another running
instance, and neither of the proposed actions in the error message will
work. At the very least, the error message needs fixing.
Comment 3 Matěj Cepl 2008-10-30 05:14:57 EDT
If you want to continue this discussion, we filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=462311) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.