This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 449192 - Host declaration at /usr/share/doc/dhcp-3.0.6/dhcpd.conf.sample are not global
Host declaration at /usr/share/doc/dhcp-3.0.6/dhcpd.conf.sample are not global
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 21:59 EDT by koogatakes
Modified: 2008-08-06 17:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 17:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description koogatakes 2008-05-30 21:59:34 EDT
Description of problem:


Version-Release number of selected component (if applicable):
dhcp-3.0.6-12.fc8

How reproducible:
Make dhcp.conf based /usr/share/doc/dhcp-3.0.6/dhcpd.conf.sample, use host
declaration.

Steps to Reproduce:
1.Make dhcp.conf based /usr/share/doc/dhcp-3.0.6/dhcpd.conf.sample, use host
declaration.
2.Start dhcpd.
3.Check /var/log/messages, confirm the following sentence.
" WARNING: Host declarations are global.  They are not limited to the scope you
declared them in."
  
Actual results:
The dhcpd don't provide any problems.
But I confirm the warning messages on syslog.

Expected results:
The waring messages isn't given.

Additional info:
I moved the host declarations to global scope at dhcpd.conf,and warning messages
expired.
In the example of "man dhcpd.conf", host declarations has been described
assuming that global of.
Comment 1 David Cantrell 2008-07-01 22:30:41 EDT
Can you provide the exact dhcpd.conf file you used?
Comment 2 David Cantrell 2008-08-06 17:28:24 EDT
The dhcpd.conf.sample file provided in Fedora 9 and later is more correct.  I am unable to reproduce this problem in F-9 or rawhide.  I used the dhcpd.conf.sample file and modified it only slightly.

Note You need to log in before you can comment on or make changes to this bug.