Bug 449196 - Mismatch in kernel & kernel-devel
Mismatch in kernel & kernel-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 23:38 EDT by Syam
Modified: 2008-06-02 07:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 07:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Syam 2008-05-30 23:38:20 EDT
Description of problem:
I did a yum update a couple of days ago, and my system is updated now. I 
noticed this problem today when compiling NVIDIA drivers.
I seem to have two kernels installed:
2.6.25.3-18.fc9.i686 (I'm running this one, the default in my grub)
2.6.25-14.fc9.i686

For compiling NVIDIA drivers, I did:
yum install kernel-headers
and it downloaded headers for 2.6.25-14 (confirmed from /usr/src/
kernels/2.6.25-14.fc9.i686).
Since the two kernel versions have different numbering schemes, I'm not able to 
identify the newer kernel.

Which one is the new kernel?
Comment 1 Syam 2008-05-30 23:53:30 EDT
I had changed mirrorlist for fedoa-updates repo for using presto. I thought 
this might be causing the issue. So I changed it back to the original, and did:
yum remove kernel-devel
yum clean
yum install kernel-devel

But it's still showing 2.6.25-14 as available.
As an additional info, the kernel-headers package I have is 2.6.25.3-18.fc9.
Comment 2 Neil Horman 2008-05-31 08:56:23 EDT
https://fedoraproject.org/wiki/Packaging/NamingGuidelines#Package_Version

Package n-v-r values are ordinal.  Versions and releases are separated by the
'-', and version 2.6.25.3 is larger than version 2.6.25, meaning that
kernel-2.6.25.3-18.fc9 is newer than 2.6.25-14
Comment 3 Syam 2008-05-31 09:35:08 EDT
Thanks. I figured the versioning scheme after a bit of googling. But the 
problem with kernel-devel still exists. Yum lists only kernel-devel 
2.6.25-14.fc9, though the running kernel is the newer 2.6.25.3-18.fc9.
How do I install kernel-devel 2.6.25.3-18?
Comment 4 Neil Horman 2008-06-02 07:09:29 EDT
you just wait a few minutes, clean your yum cache with a yum clean all, and try
again.  I imagine that the devel package just got pushed a  bit later than the
base package.  Its there now:
http://download.fedora.redhat.com/pub/fedora/linux/updates/9/i386/kernel-devel-2.6.25.3-18.fc9.i686.rpm
I don't know if you need i386 or not, but its there for all the arches.

Note You need to log in before you can comment on or make changes to this bug.